Browse Source

Merge pull request #1089 from obsy/master

transmission: fix build problem with fallocate64
Steven Barth 9 years ago
parent
commit
4eee291cca

+ 1
- 1
net/transmission/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=transmission
11 11
 PKG_VERSION:=2.84
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15 15
 PKG_SOURCE_URL:=http://download-origin.transmissionbt.com/files/ http://mirrors.m0k.org/transmission/files

+ 10
- 8
net/transmission/patches/010_libtransmission_fallocate64_eglibc.patch View File

@@ -1,12 +1,14 @@
1
---- a/libtransmission/fdlimit.c	2014-07-01 20:08:59.000000000 +0300
2
-+++ b/libtransmission/fdlimit.c	2014-07-13 13:30:17.000000000 +0300
3
-@@ -22,7 +22,8 @@
1
+--- a/libtransmission/fdlimit.c
2
++++ b/libtransmission/fdlimit.c
3
+@@ -22,11 +22,6 @@
4 4
   #include <fcntl.h>
5 5
  #endif
6
- 
6
+
7 7
 -#ifdef HAVE_FALLOCATE64
8
-+/* no need to define fallocate64 in glibc/eglibc case */
9
-+#if defined(__UCLIBC__) && (HAVE_FALLOCATE64)
10
-   /* FIXME can't find the right #include voodoo to pick up the declaration.. */
11
-   extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
8
+-  /* FIXME can't find the right #include voodoo to pick up the declaration.. */
9
+-  extern int fallocate64 (int fd, int mode, uint64_t offset, uint64_t len);
10
+-#endif
11
+-
12
+ #ifdef HAVE_XFS_XFS_H
13
+  #include <xfs/xfs.h>
12 14
  #endif