|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=mpd
|
11
|
11
|
PKG_VERSION:=0.18.11
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
15
|
15
|
PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.18/
|
|
@@ -35,8 +35,8 @@ define Package/mpd/Default
|
35
|
35
|
CATEGORY:=Sound
|
36
|
36
|
TITLE:=Music Player Daemon
|
37
|
37
|
URL:=http://www.musicpd.org/
|
38
|
|
- DEPENDS:= +glib2 +libcurl +libpthread +libmpdclient $(ICONV_DEPENDS) \
|
39
|
|
- +libflac +BUILD_PATENTED:libmad +libvorbisidec
|
|
38
|
+ DEPENDS:= +glib2 +libcurl +libpthread +libmpdclient $(ICONV_DEPENDS) +libstdcpp \
|
|
39
|
+ +libflac +BUILD_PATENTED:libmad +libvorbisidec +AUDIO_SUPPORT:alsa-lib
|
40
|
40
|
endef
|
41
|
41
|
|
42
|
42
|
define Package/mpd/Default/description
|
|
@@ -50,7 +50,6 @@ define Package/mpd-full
|
50
|
50
|
$(call Package/mpd/Default)
|
51
|
51
|
TITLE+= (full)
|
52
|
52
|
DEPENDS+= \
|
53
|
|
- +AUDIO_SUPPORT:alsa-lib \
|
54
|
53
|
+libaudiofile +BUILD_PATENTED:libfaad2 +libffmpeg +libid3tag \
|
55
|
54
|
+libmms +libogg +libsndfile +libvorbis
|
56
|
55
|
PROVIDES:=mpd
|
|
@@ -128,7 +127,7 @@ CONFIGURE_ARGS += \
|
128
|
127
|
--enable-flac \
|
129
|
128
|
--enable-httpd-output \
|
130
|
129
|
$(call autoconf_bool,CONFIG_BUILD_PATENTED,mad) \
|
131
|
|
- $(call autoconf_bool,CONFIG_AUDIO_SUPPORT,oss) \
|
|
130
|
+ $(call autoconf_bool,CONFIG_AUDIO_SUPPORT,alsa) \
|
132
|
131
|
--enable-tcp \
|
133
|
132
|
--enable-un \
|
134
|
133
|
|