Browse Source

Merge pull request #975 from hnyman/collectd542

collectd: update to 5.4.2
Jo-Philipp Wich 10 years ago
parent
commit
5035ac4079

+ 2
- 2
utils/collectd/Makefile View File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=collectd
11
-PKG_VERSION:=5.4.1
11
+PKG_VERSION:=5.4.2
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://collectd.org/files/
16
-PKG_MD5SUM:=6f56c71c96573a7f4f7fb3bfab185974
16
+PKG_MD5SUM:=feff9fd0ed89e956d7cf12ba18cfc248
17 17
 
18 18
 PKG_FIXUP:=autoreconf
19 19
 PKG_REMOVE_FILES:=aclocal.m4 libltdl/aclocal.m4

+ 1
- 1
utils/collectd/patches/100-rrdtool-add-rrasingle-option.patch View File

@@ -34,7 +34,7 @@
34 34
  		double tmp = atof (value);
35 35
 --- a/src/utils_rrdcreate.c
36 36
 +++ b/src/utils_rrdcreate.c
37
-@@ -211,6 +211,9 @@ static int rra_get (char ***ret, const v
37
+@@ -212,6 +212,9 @@ static int rra_get (char ***ret, const v
38 38
      rts_num = rra_timespans_num;
39 39
    }
40 40
  

+ 1
- 1
utils/collectd/patches/200-fix-git-describe-error.patch View File

@@ -2,7 +2,7 @@
2 2
 +++ b/version-gen.sh
3 3
 @@ -2,7 +2,7 @@
4 4
  
5
- DEFAULT_VERSION="5.4.1.git"
5
+ DEFAULT_VERSION="5.4.2.git"
6 6
  
7 7
 -VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`"
8 8
 +#VERSION="`git describe 2> /dev/null | sed -e 's/^collectd-//'`"

+ 7
- 7
utils/collectd/patches/900-add-iwinfo-plugin.patch View File

@@ -1,6 +1,6 @@
1 1
 --- a/configure.ac
2 2
 +++ b/configure.ac
3
-@@ -568,6 +568,9 @@ AC_CHECK_HEADERS(net/pfvar.h,
3
+@@ -580,6 +580,9 @@ AC_CHECK_HEADERS(net/pfvar.h,
4 4
  have_termios_h="no"
5 5
  AC_CHECK_HEADERS(termios.h, [have_termios_h="yes"])
6 6
  
@@ -10,7 +10,7 @@
10 10
  #
11 11
  # Checks for typedefs, structures, and compiler characteristics.
12 12
  #
13
-@@ -4819,6 +4822,7 @@ plugin_interface="no"
13
+@@ -4841,6 +4844,7 @@ plugin_interface="no"
14 14
  plugin_ipmi="no"
15 15
  plugin_ipvs="no"
16 16
  plugin_irq="no"
@@ -18,7 +18,7 @@
18 18
  plugin_libvirt="no"
19 19
  plugin_load="no"
20 20
  plugin_memory="no"
21
-@@ -5157,6 +5161,7 @@ AC_PLUGIN([ipmi],        [$plugin_ipmi],
21
+@@ -5179,6 +5183,7 @@ AC_PLUGIN([ipmi],        [$plugin_ipmi],
22 22
  AC_PLUGIN([iptables],    [$with_libiptc],      [IPTables rule counters])
23 23
  AC_PLUGIN([ipvs],        [$plugin_ipvs],       [IPVS connection statistics])
24 24
  AC_PLUGIN([irq],         [$plugin_irq],        [IRQ statistics])
@@ -26,7 +26,7 @@
26 26
  AC_PLUGIN([java],        [$with_java],         [Embed the Java Virtual Machine])
27 27
  AC_PLUGIN([libvirt],     [$plugin_libvirt],    [Virtual machine statistics])
28 28
  AC_PLUGIN([load],        [$plugin_load],       [System load])
29
-@@ -5458,6 +5463,7 @@ Configuration:
29
+@@ -5480,6 +5485,7 @@ Configuration:
30 30
      protobuf-c  . . . . . $have_protoc_c
31 31
      oracle  . . . . . . . $with_oracle
32 32
      python  . . . . . . . $with_python
@@ -34,7 +34,7 @@
34 34
  
35 35
    Features:
36 36
      daemon mode . . . . . $enable_daemon
37
-@@ -5502,6 +5508,7 @@ Configuration:
37
+@@ -5524,6 +5530,7 @@ Configuration:
38 38
      iptables  . . . . . . $enable_iptables
39 39
      ipvs  . . . . . . . . $enable_ipvs
40 40
      irq . . . . . . . . . $enable_irq
@@ -52,7 +52,7 @@
52 52
  #@BUILD_PLUGIN_JAVA_TRUE@LoadPlugin java
53 53
  #@BUILD_PLUGIN_LIBVIRT_TRUE@LoadPlugin libvirt
54 54
  @BUILD_PLUGIN_LOAD_TRUE@@BUILD_PLUGIN_LOAD_TRUE@LoadPlugin load
55
-@@ -467,6 +468,12 @@
55
+@@ -502,6 +503,12 @@
56 56
  #	IgnoreSelected true
57 57
  #</Plugin>
58 58
  
@@ -67,7 +67,7 @@
67 67
  #	JVMArg "-Djava.class.path=@prefix@/share/collectd/java/collectd-api.jar"
68 68
 --- a/src/collectd.conf.pod
69 69
 +++ b/src/collectd.conf.pod
70
-@@ -2056,6 +2056,27 @@ and all other interrupts are collected.
70
+@@ -2077,6 +2077,27 @@ and all other interrupts are collected.
71 71
  
72 72
  =back
73 73
  

+ 0
- 31
utils/collectd/patches/905-fix-sigrok-upstream-patch-post-541 View File

@@ -1,31 +0,0 @@
1
---- a/configure.ac
2
-+++ b/configure.ac
3
-@@ -3825,18 +3825,20 @@ AC_ARG_WITH(libsigrok, [AS_HELP_STRING([--with-libsigrok@<:@=PREFIX@:>@], [Path
4
- 			with_libsigrok_ldflags="-L$withval/lib"
5
- 		fi
6
- 	fi
7
--],[])
8
-+],[with_libsigrok="yes"])
9
- 
10
- # libsigrok has a glib dependency
11
- if test "x$with_libsigrok" = "xyes"
12
- then
13
--	if test -z "m4_ifdef([AM_PATH_GLIB_2_0], [yes], [])"
14
--	then
15
--		with_libsigrok="no (glib not available)"
16
--	else
17
--		AM_PATH_GLIB_2_0([2.28.0],
18
--			[with_libsigrok_cflags="$with_libsigrok_cflags $GLIB_CFLAGS"; with_libsigrok_ldflags="$with_libsigrok_ldflags $GLIB_LIBS"])
19
--	fi
20
-+m4_ifdef([AM_PATH_GLIB_2_0],
21
-+	[
22
-+	 AM_PATH_GLIB_2_0([2.28.0],
23
-+	 	[with_libsigrok_cflags="$with_libsigrok_cflags $GLIB_CFLAGS"; with_libsigrok_ldflags="$with_libsigrok_ldflags $GLIB_LIBS"])
24
-+	],
25
-+	[
26
-+	 with_libsigrok="no (glib not available)"
27
-+	]
28
-+)
29
- fi
30
- 
31
- # libsigrok headers