Просмотр исходного кода

Merge pull request #621 from thess/mjpg-streamer-work2

mjpg-streamer: Fix V4L2 option dependency selection and add camera led c...
Ted Hess 10 лет назад
Родитель
Сommit
5118fb2286

+ 4
- 5
multimedia/mjpg-streamer/Makefile Просмотреть файл

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 PKG_NAME:=mjpg-streamer
11 11
 PKG_REV:=182
12 12
 PKG_VERSION:=r$(PKG_REV)
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=3
14 14
 PKG_MAINTAINER:=Roger D <rogerdammit@gmail.com>
15 15
 
16 16
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).1.tar.bz2
@@ -24,14 +24,13 @@ PKG_LICENSE_FILES:=LICENSE
24 24
 
25 25
 include $(INCLUDE_DIR)/package.mk
26 26
 
27
+PKG_BUILD_DEPENDS:=MJPG_STREAMER_V4L2:libv4l
28
+
27 29
 define Package/mjpg-streamer
28 30
   SECTION:=multimedia
29 31
   CATEGORY:=Multimedia
30 32
   TITLE:=MJPG-streamer
31
-  DEPENDS:=+libpthread +libjpeg 
32
-  ifeq ($(CONFIG_MJPG_STREAMER_V4L2),y)
33
-	DEPENDS+=+libv4l
34
-  endif
33
+  DEPENDS:=+libpthread +libjpeg +PACKAGE_libv4l:libv4l
35 34
   URL:=http://mjpg-streamer.wiki.sourceforge.net/
36 35
   MENU:=1
37 36
 endef

+ 2
- 0
multimedia/mjpg-streamer/files/mjpg-streamer.config Просмотреть файл

@@ -1,3 +1,4 @@
1
+
1 2
 config mjpg-streamer 'core'
2 3
 	option enabled '0'
3 4
 	option input 'uvc'
@@ -5,6 +6,7 @@ config mjpg-streamer 'core'
5 6
 	option device '/dev/video0'
6 7
 	option resolution '640x480'
7 8
 	option fps '5'
9
+	option led 'auto'
8 10
 	option www '/www/webcam'
9 11
 	option port '8080'
10 12
 	option username 'openwrt'

+ 4
- 1
multimedia/mjpg-streamer/files/mjpg-streamer.init Просмотреть файл

@@ -1,5 +1,5 @@
1 1
 #!/bin/sh /etc/rc.common
2
-# Copyright (C) 2009-2013 OpenWrt.org
2
+# Copyright (C) 2009-2014 OpenWrt.org
3 3
 
4 4
 START=90
5 5
 STOP=10
@@ -45,6 +45,9 @@ start_instance() {
45 45
 
46 46
 		config_get resolution "$s" 'resolution'
47 47
 		[ -n "$resolution" ] && input_arg="${input_arg} --resolution $resolution"
48
+
49
+		config_get led "$s" 'led'
50
+		[ -n "$led" ] && input_arg="${input_arg} --led $led"
48 51
 	fi
49 52
 
50 53
 	if [ -z "$input_arg" ]; then