Browse Source

[SQM] Fix simple.qos to allow using cake as ingress shaper

simple.qos had accidentally set up the egress shaper twice, once
with the true egress parameters and a second time using the ingress
parameters, effectively misconfiguring both directions. This bub
only affected situations where 3-tier ingress classification was
used.

Signed-off-by: Sebastian Moeller <moeller0@gmx.de>
Sebastian Moeller 9 years ago
parent
commit
517954b7f5
2 changed files with 2 additions and 2 deletions
  1. 1
    1
      net/sqm-scripts/Makefile
  2. 1
    1
      net/sqm-scripts/files/usr/lib/sqm/simple.qos

+ 1
- 1
net/sqm-scripts/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=sqm-scripts
11 11
 PKG_VERSION:=8
12
-PKG_RELEASE:=6
12
+PKG_RELEASE:=7
13 13
 PKG_LICENSE:=GPLv2
14 14
 
15 15
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)

+ 1
- 1
net/sqm-scripts/files/usr/lib/sqm/simple.qos View File

@@ -177,7 +177,7 @@ else
177 177
     sqm_logger "Perform DSCP based filtering on ingress. (3-tier classification)"
178 178
     case $QDISC in
179 179
     	    cake*) 
180
-    		    $TC qdisc add dev $IFACE root `get_stab_string` $QDISC bandwidth ${DOWNLINK}kbit `get_cake_lla_string` $CAKE_OPTS ${IQDISC_OPTS}
180
+    		    $TC qdisc add dev $DEV root `get_stab_string` $QDISC bandwidth ${DOWNLINK}kbit `get_cake_lla_string` $CAKE_OPTS ${IQDISC_OPTS}
181 181
     		    ;;
182 182
 	    *) 	
183 183
 		    $TC qdisc add dev $DEV root handle 1: `get_stab_string` htb default 12