Browse Source

scapy: add new package

Signed-off-by: W. Michael Petullo <mike@flyn.org>
W. Michael Petullo 9 years ago
parent
commit
51adbf46d4
1 changed files with 56 additions and 0 deletions
  1. 56
    0
      net/scapy/Makefile

+ 56
- 0
net/scapy/Makefile View File

@@ -0,0 +1,56 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=scapy
11
+PKG_VERSION:=2.2.0
12
+PKG_RELEASE:=1
13
+PKG_LICENSE:=GPL-2.0
14
+PKG_LICENSE_FILES:=PKG-INFO
15
+
16
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).zip
17
+PKG_SOURCE_URL:=https://bitbucket.org/secdev/scapy/downloads/
18
+PKG_MD5SUM:=d68903c5d877820026dc544caa0b5d3c
19
+
20
+PKG_BUILD_DEPENDS:=python python-setuptools
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+$(call include_mk, python-package.mk)
24
+
25
+define Package/scapy
26
+  SECTION:=net
27
+  CATEGORY:=Network
28
+  TITLE:=Interactive packet manipulation tool and network scanner
29
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
30
+  URL:=http://www.secdev.org/projects/scapy/
31
+  DEPENDS:=+python
32
+endef
33
+
34
+define Package/scapy/description
35
+  Scapy is a powerful interactive packet manipulation program built on top
36
+  of the Python interpreter. It can be used to forge or decode packets of
37
+  a wide number of protocols, send them over the wire, capture them, match
38
+  requests and replies, and much more.
39
+endef
40
+
41
+define Build/Compile
42
+	$(call Build/Compile/PyMod,., \
43
+		install --prefix="/usr" --root="$(PKG_INSTALL_DIR)", \
44
+	)
45
+endef
46
+
47
+define Package/scapy/install
48
+	$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
49
+	$(INSTALL_DIR) $(1)/usr/bin
50
+	$(CP) \
51
+		$(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
52
+		$(1)$(PYTHON_PKG_DIR)/
53
+	$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
54
+endef
55
+
56
+$(eval $(call BuildPackage,scapy))