Browse Source

gnutls: corrected regression with camellia cipher

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 9 years ago
parent
commit
5244681f2d

+ 1
- 1
libs/gnutls/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnutls
11 11
 PKG_VERSION:=3.4.1
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 PKG_USE_MIPS16:=0
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz

+ 26
- 0
libs/gnutls/patches/001-camellia256-gcm-corrected-regression.patch View File

@@ -0,0 +1,26 @@
1
+From 6adde30fcea02d3cb541b5a5bfb3b12074f1f3e9 Mon Sep 17 00:00:00 2001
2
+From: Nikos Mavrogiannopoulos <nmav@redhat.com>
3
+Date: Thu, 14 May 2015 14:00:11 +0200
4
+Subject: [PATCH] camellia256-gcm: corrected regression
5
+
6
+Reported by Manuel Pegourie-Gonnard.
7
+---
8
+ lib/nettle/cipher.c | 2 +-
9
+ 1 file changed, 1 insertion(+), 1 deletion(-)
10
+
11
+diff --git a/lib/nettle/cipher.c b/lib/nettle/cipher.c
12
+index 59e70dd..74e4203 100644
13
+--- a/lib/nettle/cipher.c
14
++++ b/lib/nettle/cipher.c
15
+@@ -302,7 +302,7 @@ static const struct nettle_cipher_st builtin_ciphers[] = {
16
+ 	   .ctx_size = sizeof(struct gcm_camellia256_ctx),
17
+ 	   .encrypt = _gcm_encrypt,
18
+ 	   .decrypt = _gcm_decrypt,
19
+-	   .set_encrypt_key = (nettle_set_key_func*)gcm_camellia128_set_key,
20
++	   .set_encrypt_key = (nettle_set_key_func*)gcm_camellia256_set_key,
21
+ 	   .set_decrypt_key = (nettle_set_key_func*)gcm_camellia256_set_key,
22
+ 	   
23
+ 	   .tag = (nettle_hash_digest_func*)gcm_camellia256_digest,
24
+-- 
25
+2.1.4
26
+