Browse Source

Merge pull request #525 from commodo/python-env-launcher

python: add __PYENV_LAUNCHER__ env var
sbyx 10 years ago
parent
commit
52f72ea696
1 changed files with 1 additions and 0 deletions
  1. 1
    0
      lang/python/files/python-package.mk

+ 1
- 0
lang/python/files/python-package.mk View File

@@ -89,6 +89,7 @@ define Build/Compile/PyMod
89 89
 		CPPFLAGS="$(TARGET_CPPFLAGS) -I$(PYTHON_INC_DIR)" \
90 90
 		LDFLAGS="$(TARGET_LDFLAGS) -lpython$(PYTHON_VERSION)" \
91 91
 		_PYTHON_HOST_PLATFORM="linux-$(ARCH)" \
92
+		__PYVENV_LAUNCHER__="/usr/bin/$(PYTHON)" \
92 93
 		$(3) \
93 94
 		, \
94 95
 		./setup.py $(2) \