Browse Source

Merge pull request #1412 from jow-/libdaq-musl-compat

libdaq: fix musl compatibility
Luka Perkov 9 years ago
parent
commit
530772b9d0

+ 1
- 1
libs/libdaq/Makefile View File

@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libdaq
11 11
 PKG_VERSION:=2.0.4
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE_URL:=https://www.snort.org/downloads/snort/ \
15 15
 	@SF/snort

+ 5
- 5
libs/libdaq/patches/001-compile.patch View File

@@ -1,8 +1,8 @@
1
---- daq-1.1.1/configure	2012-07-10 21:32:51.000000000 +0200
2
-+++ daq-new/configure	2012-08-03 15:47:07.654945651 +0200
3
-@@ -12717,10 +12717,11 @@
4
-     { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libpcap version >= \"1.0.0\"" >&5
5
- $as_echo_n "checking for libpcap version >= \"1.0.0\"... " >&6; }
1
+--- a/configure
2
++++ b/configure
3
+@@ -12967,10 +12967,11 @@ if ${daq_cv_libpcap_version_1x+:} false;
4
+ else
5
+ 
6 6
      if test "$cross_compiling" = yes; then :
7 7
 -  { { $as_echo "$as_me:${as_lineno-$LINENO}: error: in \`$ac_pwd':" >&5
8 8
 -$as_echo "$as_me: error: in \`$ac_pwd':" >&2;}

+ 42
- 0
libs/libdaq/patches/100-musl-compat.patch View File

@@ -0,0 +1,42 @@
1
+--- a/os-daq-modules/daq_ipfw.c
2
++++ b/os-daq-modules/daq_ipfw.c
3
+@@ -23,10 +23,10 @@
4
+ #include <stdlib.h>
5
+ #include <string.h>
6
+ #include <stdio.h>
7
++#include <unistd.h>
8
+ 
9
+ #include <sys/types.h>
10
+ #include <sys/time.h>
11
+-#include <sys/unistd.h>
12
+ 
13
+ #include <netinet/in.h>
14
+ #include <sys/socket.h>
15
+--- a/os-daq-modules/daq_ipq.c
16
++++ b/os-daq-modules/daq_ipq.c
17
+@@ -24,10 +24,10 @@
18
+ #include <stdio.h>
19
+ #include <stdlib.h>
20
+ #include <string.h>
21
++#include <unistd.h>
22
+ 
23
+ #include <sys/types.h>
24
+ #include <sys/time.h>
25
+-#include <sys/unistd.h>
26
+ 
27
+ #include <netinet/ip.h>
28
+ 
29
+--- a/os-daq-modules/daq_nfq.c
30
++++ b/os-daq-modules/daq_nfq.c
31
+@@ -24,10 +24,10 @@
32
+ #include <stdio.h>
33
+ #include <stdlib.h>
34
+ #include <string.h>
35
++#include <unistd.h>
36
+ 
37
+ #include <sys/types.h>
38
+ #include <sys/time.h>
39
+-#include <sys/unistd.h>
40
+ 
41
+ #include <netinet/ip.h>
42
+