|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2007 OpenWrt.org
|
|
2
|
+# Copyright (C) 2007-2014 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -8,21 +8,23 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=bmon
|
11
|
|
-PKG_VERSION:=2.1.0
|
|
11
|
+PKG_VERSION:=3.5
|
12
|
12
|
PKG_RELEASE:=1
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
15
|
|
-PKG_SOURCE_URL:=http://people.suug.ch/~tgr/bmon/files/
|
16
|
|
-PKG_MD5SUM:=3111a027907016c0902d67350c619df6
|
|
15
|
+PKG_SOURCE_URL:=https://github.com/tgraf/bmon/releases/download/v$(PKG_VERSION)/
|
|
16
|
+PKG_MD5SUM:=b7d0d055727f2cf1e452f26dfbf6a825
|
|
17
|
+PKG_MAINTAINER:=Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
|
|
18
|
+PKG_LICENSE:=MIT
|
17
|
19
|
|
18
|
20
|
include $(INCLUDE_DIR)/package.mk
|
19
|
21
|
|
20
|
22
|
define Package/bmon
|
21
|
23
|
SECTION:=net
|
22
|
24
|
CATEGORY:=Network
|
23
|
|
- DEPENDS:=+libncurses
|
|
25
|
+ DEPENDS:=+libncurses +libnl +confuse
|
24
|
26
|
TITLE:=bmon is a portable bandwidth monitor
|
25
|
|
- URL:=http://people.suug.ch/~tgr/bmon/
|
|
27
|
+ URL:=https://github.com/tgraf/bmon/
|
26
|
28
|
endef
|
27
|
29
|
|
28
|
30
|
define Package/bmon/description
|