|
@@ -0,0 +1,46 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=make
|
|
11
|
+PKG_VERSION:=4.1
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE_URL:=@GNU/make
|
|
15
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
16
|
+PKG_MD5SUM:=654f9117957e6fa6a1c49a8f08270ec9
|
|
17
|
+PKG_MAINTAINER:=Heinrich Schuchardt <xypron.glpk@gmx.de>
|
|
18
|
+PKG_LICENSE:=GPL-3.0+
|
|
19
|
+
|
|
20
|
+PKG_INSTALL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/make
|
|
25
|
+ SECTION:=devel
|
|
26
|
+ CATEGORY:=Development
|
|
27
|
+ TITLE:=make
|
|
28
|
+ URL:=https://www.gnu.org/software/make/
|
|
29
|
+endef
|
|
30
|
+
|
|
31
|
+define Package/make/description
|
|
32
|
+ The Make package contains a tool to create executables from source files.
|
|
33
|
+endef
|
|
34
|
+
|
|
35
|
+define Package/make/install
|
|
36
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
37
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/make $(1)/usr/bin/
|
|
38
|
+endef
|
|
39
|
+
|
|
40
|
+# provide gnumake.h at build time for other packages
|
|
41
|
+define Build/InstallDev
|
|
42
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
43
|
+ $(CP) $(PKG_BUILD_DIR)/gnumake.h $(1)/usr/include/
|
|
44
|
+endef
|
|
45
|
+
|
|
46
|
+$(eval $(call BuildPackage,make))
|