Browse Source

libxml2: upgrade to 2.9.3

Beside some improvements, this also fixes several CVEs, for full
list see upstream changelog at:
https://mail.gnome.org/archives/xml/2015-November/msg00012.html

The patch needed for musl was accepted upstream, so we can remove it.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
Michael Heimpold 9 years ago
parent
commit
55421fe27b

+ 4
- 4
libs/libxml2/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -8,14 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libxml2
11
-PKG_VERSION:=2.9.2
12
-PKG_RELEASE:=3
11
+PKG_VERSION:=2.9.3
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://gd.tuwien.ac.at/languages/libxml/ \
16 16
 	http://xmlsoft.org/sources/ \
17 17
 	ftp://fr.rpmfind.net/pub/libxml/
18
-PKG_MD5SUM:=9e6a9aca9d155737868b3dc5fd82f788
18
+PKG_MD5SUM:=daece17e045f1c107610e137ab50c179
19 19
 
20 20
 PKG_LICENSE:=MIT
21 21
 PKG_LICENSE_FILES:=COPYING

+ 0
- 42
libs/libxml2/patches/0001-threads-use-forward-declarations-only-for-glibc-fixe.patch View File

@@ -1,42 +0,0 @@
1
-From e3e04d254fb6bac49a285775b729e28b0500476c Mon Sep 17 00:00:00 2001
2
-From: Michael Heimpold <mhei@heimpold.de>
3
-Date: Sun, 21 Dec 2014 01:03:49 +0100
4
-Subject: [PATCH] threads: use forward declarations only for glibc (fixes
5
- #704908)
6
-
7
-The declarations of pthread functions, used to generate weak references
8
-to them, fail to suppress macros. Thus, if any pthread function has
9
-been provided as a macro, compiling threads.c will fail.
10
-This breaks on musl libc, which defines pthread_equal as a macro (in
11
-addition to providing the function, as required).
12
-
13
-Prevent the declarations for e.g. musl libc by refining the condition.
14
-
15
-The idea for this solution was borrowed from the alpine linux guys, see
16
-http://git.alpinelinux.org/cgit/aports/tree/main/libxml2/libxml2-pthread.patch
17
-
18
-Signed-off-by: Michael Heimpold <mhei@heimpold.de>
19
----
20
- threads.c |    4 ++--
21
- 1 file changed, 2 insertions(+), 2 deletions(-)
22
-
23
---- a/threads.c
24
-+++ b/threads.c
25
-@@ -47,7 +47,7 @@
26
- #ifdef HAVE_PTHREAD_H
27
- 
28
- static int libxml_is_threaded = -1;
29
--#ifdef __GNUC__
30
-+#if defined(__GNUC__) && defined(__GLIBC__)
31
- #ifdef linux
32
- #if (__GNUC__ == 3 && __GNUC_MINOR__ >= 3) || (__GNUC__ > 3)
33
- extern int pthread_once (pthread_once_t *__once_control,
34
-@@ -89,7 +89,7 @@ extern int pthread_cond_signal ()
35
- 	   __attribute((weak));
36
- #endif
37
- #endif /* linux */
38
--#endif /* __GNUC__ */
39
-+#endif /* defined(__GNUC__) && defined(__GLIBC__) */
40
- #endif /* HAVE_PTHREAD_H */
41
- 
42
- /*