|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2014-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=opus
|
11
|
11
|
PKG_VERSION:=1.1
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
15
|
15
|
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/opus/
|
|
@@ -31,11 +31,15 @@ define Package/libopus
|
31
|
31
|
endef
|
32
|
32
|
|
33
|
33
|
define Package/libopus/description
|
34
|
|
- Opus is a totally open, royalty-free, highly versatile audio codec. Opus is
|
35
|
|
- unmatched for interactive speech and music transmission over the Internet, but
|
|
34
|
+ Opus is a totally open, royalty-free, highly versatile audio codec. Opus is
|
|
35
|
+ unmatched for interactive speech and music transmission over the Internet, but
|
36
|
36
|
is also intended for storage and streaming applications.
|
37
|
37
|
endef
|
38
|
38
|
|
|
39
|
+CONFIGURE_ARGS+= \
|
|
40
|
+ --disable-doc \
|
|
41
|
+ --disable-extra-programs
|
|
42
|
+
|
39
|
43
|
define Build/InstallDev
|
40
|
44
|
$(INSTALL_DIR) $(1)/usr/include
|
41
|
45
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/opus $(1)/usr/include/
|