Browse Source

FAAD2: Update pkg copyright/version, fix fixed-point builds, add myself as pkg maintainer

Signed-off-by: Ted Hess <thess@kitschensync.net>
thess 10 years ago
parent
commit
57ae91f5f2
1 changed files with 5 additions and 2 deletions
  1. 5
    2
      libs/faad2/Makefile

+ 5
- 2
libs/faad2/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2008 OpenWrt.org
2
+# Copyright (C) 2008-2014 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,11 +9,12 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=faad2
11 11
 PKG_VERSION:=2.7
12
-PKG_RELEASE:=2
12
+PKG_RELEASE:=3
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=@SF/faac
16 16
 PKG_MD5SUM:=4c332fa23febc0e4648064685a3d4332
17
+PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
17 18
 
18 19
 PKG_CONFIG_DEPENDS := \
19 20
 	CONFIG_SOFT_FLOAT \
@@ -30,6 +31,7 @@ TARGET_CFLAGS += $(FPIC)
30 31
 # specifically ask to use floats anyways.
31 32
 ifeq ($(CONFIG_SOFT_FLOAT)-$(CONFIG_FAAD2_ALWAYS_USE_FLOATING_POINT),y-)
32 33
 TARGET_CFLAGS+= -DFIXED_POINT
34
+FAAD2_CONFIG_OPTS= --without-fp -nfp
33 35
 endif
34 36
 
35 37
 define Package/faad2/Default
@@ -84,6 +86,7 @@ define Build/Configure
84 86
 	);
85 87
 	$(call Build/Configure/Default, \
86 88
 		--with-mp4v2 \
89
+		$(FAAD2_CONFIG_OPTS) \
87 90
 		--without-xmms \
88 91
 		, \
89 92
 		FAAD2_CPPFLAGS="-fno-builtin-cos -fno-builtin-sin -fno-builtin-log" \