Browse Source

Merge pull request #1020 from commodo/python-updates

python: revert previous patch and add a filespec
Steven Barth 10 years ago
parent
commit
58245f257f
1 changed files with 3 additions and 3 deletions
  1. 3
    3
      lang/python/Makefile

+ 3
- 3
lang/python/Makefile View File

@@ -209,8 +209,8 @@ define PyPackage/python-base/install
209 209
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpython$(PYTHON_VERSION).so* $(1)/usr/lib/
210 210
 endef
211 211
 
212
-# Dummy rule so that the package gets picked up
213
-define Package/python/install
212
+define PyPackage/python/filespec
213
+-|$(PYTHON_PKG_DIR)
214 214
 endef
215 215
 
216 216
 HOST_CFLAGS+= \
@@ -241,7 +241,7 @@ $(foreach package, $(PYTHON_PACKAGES),  \
241 241
 
242 242
 $(eval $(call PyPackage,python-base))
243 243
 $(eval $(call PyPackage,python-light))
244
-#$(eval $(call PyPackage,python))
244
+$(eval $(call PyPackage,python))
245 245
 
246 246
 $(eval $(call BuildPackage,python-base))
247 247
 $(eval $(call BuildPackage,python-light))