Browse Source

libs/libsodium: add LIBSODIUM_MINIMAL

Moritz Warning 10 years ago
parent
commit
5948b0a632
1 changed files with 11 additions and 1 deletions
  1. 11
    1
      libs/libsodium/Makefile

+ 11
- 1
libs/libsodium/Makefile View File

@@ -43,7 +43,17 @@ define Package/libsodium/description
43 43
   And despite the emphasis on higher security, primitives are faster across-the-board than most implementations of the NIST standards.
44 44
 endef
45 45
 
46
-CONFIGURE_ARGS += --disable-ssp
46
+define Package/libsodium/config
47
+menu "Configuration"
48
+	config LIBSODIUM_MINIMAL
49
+		bool "Create a smaller library"
50
+		default n
51
+endmenu
52
+endef
53
+
54
+CONFIGURE_ARGS+= \
55
+	--disable-ssp \
56
+	$(if $(CONFIG_LIBSODIUM_MINIMAL),--enable-minimal=yes,--enable-minimal=no)
47 57
 
48 58
 define Build/InstallDev
49 59
 	$(INSTALL_DIR) $(1)/usr/include/sodium