Browse Source

db47: Drop -full variant and integrate it into the normal one

Signed-off-by: Marcel Denia <naoir@gmx.net>
Marcel Denia 10 years ago
parent
commit
5ab2c7cffd
1 changed files with 10 additions and 68 deletions
  1. 10
    68
      libs/db47/Makefile

+ 10
- 68
libs/db47/Makefile View File

@@ -12,9 +12,9 @@ BASE_VERSION:=4.7.25
12 12
 
13 13
 PKG_NAME:=db47
14 14
 PKG_VERSION:=$(BASE_VERSION).4.NC
15
-PKG_RELEASE:=2
15
+PKG_RELEASE:=3
16 16
 
17
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/db-$(BASE_VERSION).NC
17
+PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(BASE_VERSION).NC
18 18
 PKG_SOURCE:=db-$(BASE_VERSION).NC.tar.gz
19 19
 PKG_SOURCE_URL:=http://download.oracle.com/berkeley-db/
20 20
 PKG_MD5SUM:=073ab7f20d24b3872a51ca762f5090e7
@@ -29,71 +29,30 @@ PKG_BUILD_PARALLEL:=1
29 29
 
30 30
 include $(INCLUDE_DIR)/package.mk
31 31
 
32
-define Package/libdb47/Default
32
+define Package/libdb47
33 33
   SECTION:=libs
34 34
   CATEGORY:=Libraries
35 35
   DEPENDS:=+libxml2
36
-  PROVIDES:=libdb47
36
+  TITLE:=Berkeley DB library (4.7)
37 37
   URL:=http://www.oracle.com/us/products/database/berkeley-db
38
-endef
39
-
40
-define Package/libdb47/Default/description
41
-  Berkeley DB library (4.7).
42
-endef
43
-
44
-define Package/libdb47
45
-$(call Package/libdb47/Default)
46
-  VARIANT:=small
47
-  TITLE:=Berkeley DB library (4.7) (without statistics etc. support)
38
+  PROVIDES:=libdb47-full
48 39
 endef
49 40
 
50 41
 define Package/libdb47/description
51
-$(call Package/libdb47/Default/description)
52
- This package is not built with statistics etc. support.
53
-endef
54
-
55
-define Package/libdb47-full
56
-$(call Package/libdb47/Default)
57
-  VARIANT:=full
58
-  TITLE:=Berkeley DB library (4.7) (with statistics etc. support)
59
-endef
60
-
61
-define Package/libdb47-full/description
62
-$(call Package/libdb47/Default/description)
63
- This package is built with statistics etc. support.
42
+  Berkeley DB library (4.7).
64 43
 endef
65 44
 
66
-define Package/libdb47xx/Default
45
+define Package/libdb47xx
67 46
   SECTION:=libs
68 47
   CATEGORY:=Libraries
69 48
   DEPENDS:=+libdb47 $(CXX_DEPENDS)
49
+  TITLE:=Berkeley DB library (4.7) for C++
70 50
   URL:=http://www.oracle.com/us/products/database/berkeley-db
71
-endef
72
-
73
-define Package/libdb47xx/Default/description
74
-  Berkeley DB library (4.7).  C++ wrapper.
75
-endef
76
-
77
-define Package/libdb47xx
78
-$(call Package/libdb47xx/Default)
79
-  VARIANT:=small
80
-  TITLE:=Berkeley DB library (4.7) for C++ (without statistics etc. support)
51
+  PROVIDES:=libdb47xx-full
81 52
 endef
82 53
 
83 54
 define Package/libdb47xx/description
84
-$(call Package/libdb47xx/Default/description)
85
- This package is not built with statistics etc. support.
86
-endef
87
-
88
-define Package/libdb47xx-full
89
-$(call Package/libdb47xx/Default)
90
-  VARIANT:=full
91
-  TITLE:=Berkeley DB library (4.7) for C++ (with statistics etc. support)
92
-endef
93
-
94
-define Package/libdb47xx-full/description
95
-$(call Package/libdb47xx/Default/description)
96
- This package is built with statistics etc. support.
55
+  Berkeley DB library (4.7).  C++ wrapper.
97 56
 endef
98 57
 
99 58
 CONFIGURE_PATH = build_unix
@@ -108,13 +67,8 @@ CONFIGURE_ARGS += \
108 67
 	--disable-rpc \
109 68
 	--enable-compat185 \
110 69
 	--disable-debug \
111
-	--enable-cryptography \
112 70
 	$(if $(CONFIG_PACKAGE_libdb47xx),--enable-cxx,--disable-cxx)
113 71
 
114
-ifeq ($(BUILD_VARIANT),small)
115
-        CONFIGURE_ARGS += --enable-smallbuild
116
-endif
117
-
118 72
 TARGET_CFLAGS += $(FPIC)
119 73
 
120 74
 define Build/Compile
@@ -129,21 +83,11 @@ define Package/libdb47/install
129 83
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb-*.so $(1)/usr/lib/
130 84
 endef
131 85
 
132
-define Package/libdb47-full/install
133
-	$(INSTALL_DIR) $(1)/usr/lib
134
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb-*.so $(1)/usr/lib/
135
-endef
136
-
137 86
 define Package/libdb47xx/install
138 87
 	$(INSTALL_DIR) $(1)/usr/lib
139 88
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb_cxx-*.so $(1)/usr/lib/
140 89
 endef
141 90
 
142
-define Package/libdb47xx-full/install
143
-	$(INSTALL_DIR) $(1)/usr/lib
144
-	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb_cxx-*.so $(1)/usr/lib/
145
-endef
146
-
147 91
 define Build/InstallDev
148 92
 	$(INSTALL_DIR) $(1)/usr/include
149 93
 	$(CP) $(PKG_INSTALL_DIR)/usr/include/db.h $(1)/usr/include/
@@ -153,6 +97,4 @@ define Build/InstallDev
153 97
 endef
154 98
 
155 99
 $(eval $(call BuildPackage,libdb47))
156
-$(eval $(call BuildPackage,libdb47-full))
157 100
 $(eval $(call BuildPackage,libdb47xx))
158
-$(eval $(call BuildPackage,libdb47xx-full))