|
@@ -8,12 +8,12 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=jpeg
|
11
|
|
-PKG_VERSION:=6b
|
|
11
|
+PKG_VERSION:=9a
|
12
|
12
|
PKG_RELEASE:=1
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)src.v$(PKG_VERSION).tar.gz
|
15
|
|
-PKG_SOURCE_URL:=@SF/libjpeg
|
16
|
|
-PKG_MD5SUM:=dbd5f3b47ed13132f04c685d608a7547
|
|
15
|
+PKG_SOURCE_URL:=http://www.ijg.org/files
|
|
16
|
+PKG_MD5SUM:=3353992aecaee1805ef4109aadd433e7
|
17
|
17
|
|
18
|
18
|
PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
|
19
|
19
|
PKG_LICENSE:=IJG
|
|
@@ -55,26 +55,15 @@ HOST_CONFIGURE_ARGS += \
|
55
|
55
|
--enable-shared \
|
56
|
56
|
--enable-static \
|
57
|
57
|
|
58
|
|
-define Build/Prepare
|
59
|
|
- $(call Build/Prepare/Default)
|
60
|
|
- (cd $(PKG_BUILD_DIR); \
|
61
|
|
- rm -f ltconfig ltmain.sh libtool; \
|
62
|
|
- ln -s `which true` ltconfig; \
|
63
|
|
- ln -s $(STAGING_DIR)/host/bin/libtool libtool; \
|
64
|
|
- )
|
65
|
|
-endef
|
66
|
|
-
|
67
|
58
|
define Build/Compile
|
68
|
|
- $(INSTALL_DIR) $(PKG_INSTALL_DIR)/usr/{include,lib,bin,man/man1}
|
69
|
59
|
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
|
70
|
60
|
LIBTOOL="./libtool --tag=CC" \
|
71
|
61
|
prefix="$(PKG_INSTALL_DIR)/usr" \
|
72
|
62
|
exec_prefix="$(PKG_INSTALL_DIR)/usr" \
|
73
|
63
|
all
|
74
|
64
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
75
|
|
- prefix="$(PKG_INSTALL_DIR)/usr" \
|
76
|
|
- exec_prefix="$(PKG_INSTALL_DIR)/usr" \
|
77
|
|
- install install-headers install-lib
|
|
65
|
+ DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
66
|
+ install
|
78
|
67
|
endef
|
79
|
68
|
|
80
|
69
|
define Build/InstallDev
|