Browse Source

Merge pull request #2023 from ClaymorePT/boost_6

boost: Update 6
Ted Hess 9 years ago
parent
commit
5afc87915d
1 changed files with 70 additions and 12 deletions
  1. 70
    12
      libs/boost/Makefile

+ 70
- 12
libs/boost/Makefile View File

@@ -17,7 +17,7 @@ include $(INCLUDE_DIR)/target.mk
17 17
 
18 18
 PKG_NAME:=boost
19 19
 PKG_VERSION:=1_59_0
20
-PKG_RELEASE:=5
20
+PKG_RELEASE:=6
21 21
 
22 22
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).tar.gz
23 23
 PKG_SOURCE_URL:=@SF/boost
@@ -50,6 +50,33 @@ endef
50 50
 define Package/boost/description
51 51
 This package provides the Boost v1.59 libraries.
52 52
 Boost is a set of free, peer-reviewed, portable C++ source libraries.
53
+This package provides the following libraries:
54
+ - atomic
55
+ - chrono
56
+ - container
57
+ - context
58
+ - coroutine
59
+ - - coroutine2 (requires GCC v5 and up)
60
+ - date_time
61
+ - exception
62
+ - filesystem
63
+ - graph
64
+ - - graph-parallel
65
+ - iostreams
66
+ - locale
67
+ - log
68
+ - math
69
+ - program_options
70
+ - python
71
+ - python3
72
+ - random
73
+ - regex
74
+ - serialization
75
+ - signals
76
+ - system
77
+ - thread
78
+ - timer
79
+ - wave
53 80
 endef
54 81
 
55 82
 BOOST_LIBS =
@@ -89,23 +116,49 @@ define Package/boost/config
89 116
       depends on PACKAGE_boost
90 117
       	comment "Boost compilation options."
91 118
 	    config boost-static-libs
92
-	    	bool "Static Libraries Only"	    	
119
+	    	bool "Compile Static Libraries"
93 120
 	    	help 
94
-	    		Static compile of all selected boost libraries.
121
+	    		Compile static version of all selected boost libraries.
95 122
 	    	default n
123
+
124
+	    config boost-shared-libs
125
+	    	bool "Compile Shared Libraries"
126
+	    	help 
127
+	    		Compile shared version of all selected boost libraries.
128
+	    	default y
96 129
 	    
97 130
 	    config boost-runtime-static
98
-	    	bool "Use static version of C and C++ runtimes."	    	
131
+	    	bool "Use static version of C and C++ runtimes for static libraries."	    	
99 132
 	    	help 
100
-	    		Determines if shared or static version of C and C++ runtimes should be used.
133
+	    		Determines if shared or static version of C and C++ runtimes should be used for static libraries.
101 134
 	    	default n
102 135
 	    	select boost-static-libs
103 136
 
137
+	    config boost-runtime-shared
138
+	    	bool "Use shared version of C and C++ runtimes for shared libraries."
139
+	    	help 
140
+	    		Determines if shared or static version of C and C++ runtimes should be used for shared libraries.
141
+	    	default n
142
+	    	select boost-shared-libs
143
+
144
+
104 145
 	    config boost-multi-threading
105 146
 	    	bool "Multithread Support"	    	
106 147
 	    	help 
107
-	    		Compile Boost libraries with multithread support.
148
+	    		Compile Boost libraries n multithread mode.
108 149
 	    	default y
150
+
151
+	    config boost-single-thread
152
+	    	bool "Single thread Support"	    	
153
+	    	help 
154
+	    		Compile Boost libraries in single-thread mode.
155
+	    	default n
156
+	    
157
+	    config boost-with-debug
158
+	    	bool "Boost Debug Support"	    	
159
+	    	help 
160
+	    		Compile Boost libraries with debug support.
161
+	    	default n	    	
109 162
     endmenu
110 163
 
111 164
     menu "Select Boost libraries"
@@ -121,6 +174,7 @@ define Package/boost/config
121 174
 	    	select PACKAGE_boost-test
122 175
 	    
123 176
 		config boost-coroutine2
177
+		depends on @GCC_USE_VERSION_5
124 178
 		bool "Boost couroutine2 support."
125 179
 		select PACKAGE_boost-coroutine
126 180
 		default n
@@ -184,15 +238,14 @@ $(eval $(call DefineBoostLibrary,date_time,,))
184 238
 #$(eval $(call DefineBoostLibrary,exception,,))
185 239
 $(eval $(call DefineBoostLibrary,filesystem,system,))
186 240
 $(eval $(call DefineBoostLibrary,graph,regex,))
187
-#$(eval $(call DefineBoostLibrary,graph_parallel,,))
188 241
 $(eval $(call DefineBoostLibrary,iostreams,,+zlib))
189 242
 $(eval $(call DefineBoostLibrary,locale,system,$(ICONV_DEPENDS) +@BUILD_NLS))
190 243
 $(eval $(call DefineBoostLibrary,log,system chrono date_time thread filesystem regex,))
191 244
 $(eval $(call DefineBoostLibrary,math,,))
192 245
 #$(eval $(call DefineBoostLibrary,mpi,,)) # OpenMPI does no exist in OpenWRT at this time.
193 246
 $(eval $(call DefineBoostLibrary,program_options,,))
194
-$(eval $(call DefineBoostLibrary,python,,+python))
195
-$(eval $(call DefineBoostLibrary,python3,,+python3))
247
+$(eval $(call DefineBoostLibrary,python,,+CONFIG_boost_python:python))
248
+$(eval $(call DefineBoostLibrary,python3,,+CONFIG_boost_python3:python3))
196 249
 $(eval $(call DefineBoostLibrary,random,system,))
197 250
 $(eval $(call DefineBoostLibrary,regex,,))
198 251
 $(eval $(call DefineBoostLibrary,serialization,,))
@@ -245,11 +298,16 @@ define Build/Compile
245 298
 		bjam \
246 299
 			'-sBUILD=release <optimization>space <inlining>on <debug-symbols>off' \
247 300
 			--ignore-site-config \
248
-			--toolset=gcc-$(ARCH) --build-type=minimal --layout=system abi=$(BOOST_ABI) \
301
+			--toolset=gcc-$(ARCH) abi=$(BOOST_ABI) \
249 302
 			--disable-long-double \
250
-			$(if $(CONFIG_boost-static-libs),link=static,link=shared) \
303
+			--layout=tagged \
304
+			$(if $(CONFIG_boost-with-debug),--build-type=complete,--build-type=minimal) \
305
+			$(if $(CONFIG_boost-static-libs),link=static,) \
251 306
 			$(if $(CONFIG_boost-runtime-static),runtime-link=static,runtime-link=shared) \
252
-			$(if $(CONFIG_boost-multi-threading),threading=multi,threading=single) \
307
+			$(if $(CONFIG_boost-shared-libs),link=shared,) \
308
+			$(if $(CONFIG_boost-runtime-shared),runtime-link=shared,) \
309
+			$(if $(CONFIG_boost-single-thread),threading=single,) \
310
+			$(if $(CONFIG_boost-multi-threading),threading=multi,) \
253 311
 			$(CONFIGURE_ARGS) \
254 312
 			--without-mpi \
255 313
 			$(if $(CONFIG_boost-coroutine2),,--without-coroutine2) \