|
@@ -1,5 +1,5 @@
|
1
|
1
|
#
|
2
|
|
-# Copyright (C) 2006-2014 OpenWrt.org
|
|
2
|
+# Copyright (C) 2006-2015 OpenWrt.org
|
3
|
3
|
#
|
4
|
4
|
# This is free software, licensed under the GNU General Public License v2.
|
5
|
5
|
# See /LICENSE for more information.
|
|
@@ -8,12 +8,12 @@
|
8
|
8
|
include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=libmodbus
|
11
|
|
-PKG_VERSION:=3.0.6
|
|
11
|
+PKG_VERSION:=3.1.2
|
12
|
12
|
PKG_RELEASE:=1
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
15
|
15
|
PKG_SOURCE_URL:=http://libmodbus.org/releases
|
16
|
|
-PKG_MD5SUM:=c80f88b6ca19cabc4ceffc195ca07771
|
|
16
|
+PKG_MD5SUM:=dd4262f87ed835c4d1e560f8321a222c
|
17
|
17
|
|
18
|
18
|
PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
19
|
19
|
|
|
@@ -36,6 +36,7 @@ define Package/libmodbus/description
|
36
|
36
|
A Modbus library for Linux, Mac OS X, FreeBSD, QNX and Win32.
|
37
|
37
|
endef
|
38
|
38
|
|
|
39
|
+CONFIGURE_ARGS += --without-documentation
|
39
|
40
|
TARGET_CFLAGS += $(FPIC)
|
40
|
41
|
|
41
|
42
|
define Build/InstallDev
|