|
@@ -0,0 +1,55 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2010-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=hiredis
|
|
11
|
+PKG_VERSION:=0.13.1
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE_PROTO:=git
|
|
15
|
+PKG_SOURCE_URL:=https://github.com/redis/hiredis.git
|
|
16
|
+PKG_SOURCE_VERSION:=f58dd249d6ed47a7e835463c3b04722972281dbb
|
|
17
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
18
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
19
|
+
|
|
20
|
+PKG_LICENSE:=BSD-3-Clause
|
|
21
|
+PKG_LICENSE_FILES:=COPYING
|
|
22
|
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
|
|
23
|
+
|
|
24
|
+PKG_INSTALL:=1
|
|
25
|
+
|
|
26
|
+include $(INCLUDE_DIR)/package.mk
|
|
27
|
+
|
|
28
|
+define Package/libhiredis
|
|
29
|
+ SECTION:=libs
|
|
30
|
+ CATEGORY:=Libraries
|
|
31
|
+ TITLE:=Minimalistic C client for Redis
|
|
32
|
+ URL:=https://github.com/redis/hiredis
|
|
33
|
+endef
|
|
34
|
+
|
|
35
|
+define Package/libhiredis/description
|
|
36
|
+ Hiredis is a minimalistic C client library for the Redis database.
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+MAKE_FLAGS += ARCH="" DEBUG="" PREFIX="/usr"
|
|
40
|
+
|
|
41
|
+define Build/InstallDev
|
|
42
|
+ $(INSTALL_DIR) $(1)/usr/include/hiredis/adapters
|
|
43
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/hiredis/adapters/* $(1)/usr/include/hiredis/adapters
|
|
44
|
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/include/hiredis/*.h $(1)/usr/include/hiredis/
|
|
45
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
46
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhiredis.{so*,a} $(1)/usr/lib/
|
|
47
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/hiredis.pc $(1)/usr/lib/pkgconfig
|
|
48
|
+endef
|
|
49
|
+
|
|
50
|
+define Package/libhiredis/install
|
|
51
|
+ $(INSTALL_DIR) $(1)/usr/lib/
|
|
52
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libhiredis.so* $(1)/usr/lib/
|
|
53
|
+endef
|
|
54
|
+
|
|
55
|
+$(eval $(call BuildPackage,libhiredis))
|