|
@@ -0,0 +1,71 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2005-2011 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libgcrypt
|
|
11
|
+PKG_VERSION:=1.5.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgcrypt
|
|
16
|
+PKG_MD5SUM:=693f9c64d50c908bc4d6e01da3ff76d8
|
|
17
|
+
|
|
18
|
+PKG_FIXUP:=patch-libtool
|
|
19
|
+PKG_INSTALL:=1
|
|
20
|
+PKG_BUILD_PARALLEL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/libgcrypt
|
|
25
|
+ SECTION:=libs
|
|
26
|
+ CATEGORY:=Libraries
|
|
27
|
+ DEPENDS:=+libgpg-error
|
|
28
|
+ TITLE:=GNU crypto library
|
|
29
|
+ URL:=http://directory.fsf.org/security/libgcrypt.html
|
|
30
|
+ MAINTAINER:=W. Michael Petullo <mike@flyn.org>
|
|
31
|
+endef
|
|
32
|
+
|
|
33
|
+define Package/libgcrypt/description
|
|
34
|
+ This is a general purpose cryptographic library based on the code from
|
|
35
|
+ GnuPG. It provides functions for all cryptograhic building blocks:
|
|
36
|
+ symmetric ciphers (AES, DES, Arcfour, CAST5), hash algorithms (MD5, SHA-1,
|
|
37
|
+ RIPE-MD160, SHA-224/256, SHA-384/512), MACs (HMAC for all hash
|
|
38
|
+ algorithms), public key algorithms (RSA, DSA), large integer functions,
|
|
39
|
+ random numbers and a lot of supporting functions. Some algorithms have
|
|
40
|
+ been disabled to reduce size (Blowfish, Twofish, Serpent,
|
|
41
|
+ RC2, SEED, Camellia, CRC, MD4, TIGER-192, Whirlpool, ElGamal, ECC).
|
|
42
|
+endef
|
|
43
|
+
|
|
44
|
+CONFIGURE_ARGS += \
|
|
45
|
+ --enable-shared \
|
|
46
|
+ --enable-static \
|
|
47
|
+ --disable-asm \
|
|
48
|
+ --with-gpg-error-prefix="$(STAGING_DIR)/usr" \
|
|
49
|
+ --enable-digests="md5 rmd160 sha1 sha256 sha512" \
|
|
50
|
+ --enable-ciphers="arcfour des aes cast5" \
|
|
51
|
+ --enable-pubkey-ciphers="rsa dsa"
|
|
52
|
+
|
|
53
|
+TARGET_CFLAGS += $(FPIC)
|
|
54
|
+
|
|
55
|
+define Build/InstallDev
|
|
56
|
+ $(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/share/aclocal
|
|
57
|
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(1)/usr/bin/
|
|
58
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/gcrypt*.h $(1)/usr/include/
|
|
59
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.{la,a,so*} $(1)/usr/lib/
|
|
60
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgcrypt.m4 $(1)/usr/share/aclocal/
|
|
61
|
+ $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/libgcrypt-config
|
|
62
|
+ $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/libgcrypt-config
|
|
63
|
+ ln -sf $(STAGING_DIR)/usr/bin/libgcrypt-config $(2)/bin/
|
|
64
|
+endef
|
|
65
|
+
|
|
66
|
+define Package/libgcrypt/install
|
|
67
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
68
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.so.* $(1)/usr/lib/
|
|
69
|
+endef
|
|
70
|
+
|
|
71
|
+$(eval $(call BuildPackage,libgcrypt))
|