Browse Source

forked-daapd: update to 23.2

Signed-off-by: Espen Jürgensen <espenjurgensen+openwrt@gmail.com>
ejurgensen 9 years ago
parent
commit
5c0d034171
2 changed files with 25 additions and 24 deletions
  1. 16
    9
      sound/forked-daapd/Makefile
  2. 9
    15
      sound/forked-daapd/files/forked-daapd.conf

+ 16
- 9
sound/forked-daapd/Makefile View File

@@ -8,9 +8,9 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=forked-daapd
11
-PKG_VERSION:=22.3
12
-PKG_RELEASE:=20150222
13
-PKG_REV:=81b0d330691ce22879514af04c7d831bca8a6e19
11
+PKG_VERSION:=23.2
12
+PKG_RELEASE:=20150622
13
+PKG_REV:=227017ef5ba8df921b2f1db681a46494ec296b8b
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
16 16
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -35,29 +35,36 @@ CATEGORY:=Sound
35 35
 TITLE:=iTunes (DAAP) server for Apple Remote and AirPlay
36 36
 URL:=https://github.com/ejurgensen/forked-daapd
37 37
 DEPENDS:=+libgpg-error +libgcrypt +libgdbm +zlib +libexpat +libunistring \
38
-	+libevent2 +libdaemon +libantlr3c +confuse +glib2 +alsa-lib +libffmpeg-full \
38
+	+libevent2 +libdaemon +libantlr3c +confuse +alsa-lib +libffmpeg-full \
39 39
 	+mxml +libavahi-client +sqlite3-cli +libplist +libcurl
40 40
 endef
41 41
 
42
+define Package/forked-daapd/description
43
+  forked-daapd is a Linux/FreeBSD DAAP (iTunes), MPD (Music Player Daemon) and
44
+  RSP (Roku) media server. It has support for AirPlay devices/speakers, Apple
45
+  Remote (and compatibles), MPD clients, internet radio and LastFM. It does not
46
+  support AirPlay video.
47
+endef
48
+
42 49
 define Package/forked-daapd/conffiles
43 50
 /etc/forked-daapd.conf
44 51
 endef
45 52
 
46 53
 CONFIGURE_ARGS += \
47 54
 	--enable-itunes \
48
-	--enable-lastfm
55
+	--enable-lastfm \
56
+	--enable-mpd
49 57
 
50 58
 TARGET_CFLAGS += $(FPIC)
51 59
 TARGET_LDFLAGS += -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
52 60
 
53 61
 define Package/forked-daapd/install
62
+	$(INSTALL_DIR) $(1)/usr/sbin
63
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/forked-daapd $(1)/usr/sbin/
54 64
 	$(INSTALL_DIR) $(1)/etc
55
-	$(INSTALL_DATA) ./files/forked-daapd.conf $(1)/etc/
56
-	$(INSTALL_DIR) $(1)/usr/lib
65
+	$(INSTALL_CONF) ./files/forked-daapd.conf $(1)/etc/forked-daapd.conf
57 66
 	$(INSTALL_DIR) $(1)/usr/lib/forked-daapd
58 67
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/forked-daapd/* $(1)/usr/lib/forked-daapd/
59
-	$(INSTALL_DIR) $(1)/usr/sbin
60
-	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/forked-daapd $(1)/usr/sbin/
61 68
 	$(INSTALL_DIR) $(1)/etc/init.d
62 69
 	$(INSTALL_BIN) ./files/forked-daapd.init $(1)/etc/init.d/forked-daapd
63 70
 endef

+ 9
- 15
sound/forked-daapd/files/forked-daapd.conf View File

@@ -14,7 +14,7 @@ general {
14 14
 	uid = "daapd"
15 15
 
16 16
 	# Database location
17
-#	db_path = "/var/cache/forked-daapd/songs3.db"
17
+	db_path = "/var/cache/forked-daapd/songs3.db"
18 18
 
19 19
 	# Log file and level
20 20
 	# Available levels: fatal, log, warning, info, debug, spam
@@ -28,7 +28,7 @@ general {
28 28
 	ipv6 = no
29 29
 
30 30
 	# Location of cache database
31
-#	cache_path = "/var/cache/forked-daapd/cache.db"
31
+	cache_path = "/var/cache/forked-daapd/cache.db"
32 32
 
33 33
 	# DAAP requests that take longer than this threshold (in msec) get their
34 34
 	# replies cached for next time. Set to 0 to disable caching.
@@ -78,6 +78,12 @@ library {
78 78
 	# (changing this setting only takes effect after rescan, see the README)
79 79
 	compilation_artist = "Various artists"
80 80
 
81
+	# Internet streams in your playlists will by default be shown in the
82
+	# "Radio" library, like iTunes does. However, some clients (like
83
+	# TunesRemote+) won't show the "Radio" library. If you would also like
84
+	# to have them shown like normal playlists, you can enable this option.
85
+#	radio_playlists = false
86
+
81 87
 	# There are 5 default playlists: "Library", "Music", "Movies", "TV Shows"
82 88
 	# and "Podcasts". Here you can change the names of these playlists.
83 89
 #	name_library    = "Library"
@@ -86,6 +92,7 @@ library {
86 92
 #	name_tvshows    = "TV Shows"
87 93
 #	name_podcasts   = "Podcasts"
88 94
 #	name_audiobooks = "Audiobooks"
95
+#	name_radio      = "Radio"
89 96
 
90 97
 	# Artwork file names (without file type extension)
91 98
 	# forked-daapd will look for jpg and png files with these base names
@@ -152,19 +159,6 @@ audio {
152 159
 #	password = "s1kr3t"
153 160
 #}
154 161
 
155
-# Spotify settings (only have effect if Spotify enabled - see README/INSTALL)
156
-spotify {
157
-	# Directory where user settings should be stored (credentials)
158
-#	settings_dir = "/var/cache/forked-daapd/libspotify"
159
-
160
-	# Cache directory
161
-#	cache_dir = "/tmp"
162
-
163
-	# Set preferred bitrate for music streaming
164
-	# 0: No preference (default), 1: 96kbps, 2: 160kbps, 3: 320kbps
165
-#	bitrate = 0
166
-}
167
-
168 162
 # SQLite configuration (allows to modify the operation of the SQLite databases)
169 163
 # Make sure to read the SQLite documentation for the corresponding PRAGMA statements as
170 164
 # changing them from the defaults may increase the possibility of database corruptions!