Parcourir la source

libsigc++: adopt here

Signed-off-by: Steven Barth <steven@midlink.org>
Steven Barth il y a 10 ans
Parent
révision
5ca1327b7b

+ 62
- 0
libs/libsigc++/Makefile Voir le fichier

@@ -0,0 +1,62 @@
1
+#
2
+# Copyright (C) 2006-2012 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libsigc++
11
+PKG_VERSION:=2.3.1
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15
+PKG_SOURCE_URL:=@GNOME/libsigc++/2.3
16
+PKG_MD5SUM:=06a0569e8ba161d3428e7daa838682f8
17
+PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
18
+
19
+PKG_FIXUP:=autoreconf
20
+PKG_INSTALL:=1
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/libsigcxx
25
+  SECTION:=libs
26
+  CATEGORY:=Libraries
27
+  TITLE:=typesafe callback system for standard C++
28
+  URL:=http://libsigc.sourceforge.net/
29
+  DEPENDS:=+libstdcpp
30
+endef
31
+
32
+define Package/libsigcxx/description
33
+ It allows you to define signals and to connect those signals to any
34
+ callback function, either global or a member function, regardless of
35
+ whether it is static or virtual.
36
+endef
37
+
38
+TARGET_CFLAGS += $(FPIC)
39
+
40
+TARGET_CPPFLAGS +=  \
41
+	-fno-strict-aliasing -fno-inline \
42
+
43
+CONFIGURE_ARGS += \
44
+	--enable-shared \
45
+	--enable-static \
46
+
47
+define Build/InstallDev
48
+	$(INSTALL_DIR) $(1)/usr/include
49
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/sigc++-2.0 $(1)/usr/include/
50
+	$(INSTALL_DIR) $(1)/usr/lib
51
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.{a,so*} $(1)/usr/lib/
52
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/sigc++-2.0 $(1)/usr/lib/
53
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
54
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/sigc++-2.0.pc $(1)/usr/lib/pkgconfig/
55
+endef
56
+
57
+define Package/libsigcxx/install
58
+	$(INSTALL_DIR) $(1)/usr/lib
59
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsigc-2.0.so.* $(1)/usr/lib/
60
+endef
61
+
62
+$(eval $(call BuildPackage,libsigcxx))

+ 22
- 0
libs/libsigc++/patches/001-no_doc_tests_examples.patch Voir le fichier

@@ -0,0 +1,22 @@
1
+--- a/Makefile.am
2
++++ b/Makefile.am
3
+@@ -22,7 +22,7 @@ doc_subdirs = docs
4
+ else
5
+ doc_subdirs =
6
+ endif
7
+-SUBDIRS = sigc++ tests examples $(doc_subdirs)
8
++SUBDIRS = sigc++
9
+ 
10
+ sigc_configdir = $(libdir)/$(SIGCXX_MODULE_NAME)/include
11
+ nodist_sigc_config_HEADERS = sigc++config.h
12
+--- a/Makefile.in
13
++++ b/Makefile.in
14
+@@ -116,7 +116,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
15
+ 	distdir dist dist-all distcheck
16
+ ETAGS = etags
17
+ CTAGS = ctags
18
+-DIST_SUBDIRS = sigc++ tests examples docs
19
++DIST_SUBDIRS = sigc++
20
+ DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
21
+ distdir = $(PACKAGE)-$(VERSION)
22
+ top_distdir = $(distdir)