Selaa lähdekoodia

Merge pull request #1488 from thess/mpd-0.19-work

mpd: Upgrade to 0.19.10, refresh patches
Ted Hess 9 vuotta sitten
vanhempi
commit
5d540875a1

+ 11
- 15
sound/mpd/Makefile Näytä tiedosto

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=mpd
11
-PKG_VERSION:=0.18.23
11
+PKG_VERSION:=0.19.10
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15
-PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.18/
16
-PKG_MD5SUM:=fcdfe8b3a7a21a87b6776204e6eb7814
15
+PKG_SOURCE_URL:=http://www.musicpd.org/download/mpd/0.19/
16
+PKG_MD5SUM:=da4bc3e47afd0faf9e7a67168e012102
17 17
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
18 18
 
19 19
 PKG_LICENSE:=GPL-2.0
@@ -28,15 +28,15 @@ PKG_CONFIG_DEPENDS:= \
28 28
 PKG_INSTALL:=1
29 29
 
30 30
 include $(INCLUDE_DIR)/package.mk
31
-include $(INCLUDE_DIR)/nls.mk
32 31
 
33 32
 define Package/mpd/Default
34 33
   SECTION:=sound
35 34
   CATEGORY:=Sound
36 35
   TITLE:=Music Player Daemon
37 36
   URL:=http://www.musicpd.org/
38
-  DEPENDS:= +glib2 +libcurl +libpthread +libmpdclient $(ICONV_DEPENDS) +libstdcpp \
39
-	    +libflac +BUILD_PATENTED:libmad +libvorbisidec +AUDIO_SUPPORT:alsa-lib
37
+  DEPENDS:= +glib2 +libcurl +libpthread +libmpdclient +libstdcpp \
38
+	    +libflac +BUILD_PATENTED:libmad +libvorbisidec +AUDIO_SUPPORT:alsa-lib \
39
+            +boost +boost-container +libexpat
40 40
 endef
41 41
 
42 42
 define Package/mpd/Default/description
@@ -51,7 +51,7 @@ $(call Package/mpd/Default)
51 51
   TITLE+= (full)
52 52
   DEPENDS+= \
53 53
 	+libaudiofile +BUILD_PATENTED:libfaad2 +libffmpeg +libid3tag \
54
-	+libmms +libogg +libsndfile +libvorbis
54
+	+libmms +libogg +libsndfile +libvorbis +libupnp
55 55
   PROVIDES:=mpd
56 56
   VARIANT:=full
57 57
 endef
@@ -105,17 +105,15 @@ CONFIGURE_ARGS += \
105 105
 	$(call autoconf_bool,CONFIG_IPV6,ipv6) \
106 106
 	--disable-debug \
107 107
 	--disable-documentation \
108
-	--disable-gprof \
109 108
 	--disable-test \
110 109
 	--disable-werror \
111 110
 	\
112 111
 	--disable-ao \
113 112
 	--disable-bzip2 \
114
-	--enable-cue \
115
-	--disable-ffado \
116 113
 	--disable-fluidsynth \
117 114
 	--disable-gme \
118 115
 	--enable-inotify \
116
+	--disable-icu \
119 117
 	--disable-eventfd \
120 118
 	--disable-iso9660 \
121 119
 	--disable-jack \
@@ -126,13 +124,11 @@ CONFIGURE_ARGS += \
126 124
 	--disable-modplug \
127 125
 	--disable-mpc \
128 126
 	--disable-mpg123 \
129
-	--disable-mvp \
130 127
 	--disable-openal \
131 128
 	--disable-opus \
132 129
 	--disable-pulse \
133 130
 	--disable-sidplay \
134 131
 	--disable-solaris-output \
135
-	--disable-soup \
136 132
 	--disable-sqlite \
137 133
 	--disable-twolame-encoder \
138 134
 	--enable-wave-encoder \
@@ -155,11 +151,12 @@ CONFIGURE_VARS += \
155 151
 	$(if $(CONFIG_BUILD_PATENTED),MAD_CFLAGS="$(TARGET_CFLAGS)") \
156 152
 	$(if $(CONFIG_BUILD_PATENTED),MAD_LIBS="$(TARGET_LDFLAGS) -lmad") \
157 153
 
158
-TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib $(if $(ICONV_FULL),-liconv)
154
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
159 155
 
160 156
 ifeq ($(BUILD_VARIANT),full)
161 157
 
162 158
   CONFIGURE_ARGS += \
159
+	--enable-upnp \
163 160
 	$(call autoconf_bool,CONFIG_BUILD_PATENTED,aac) \
164 161
 	--enable-audiofile \
165 162
 	--enable-fifo \
@@ -183,14 +180,13 @@ ifeq ($(BUILD_VARIANT),mini)
183 180
 
184 181
   # oggflac is not compatible with tremor
185 182
   CONFIGURE_ARGS += \
183
+	--disable-upnp \
186 184
 	--disable-aac \
187 185
 	--disable-audiofile \
188 186
 	--disable-fifo \
189 187
 	--disable-ffmpeg \
190 188
 	--disable-id3 \
191
-	--disable-lastfm \
192 189
 	--disable-mms \
193
-	--disable-oggflac \
194 190
 	--disable-pipe-output \
195 191
 	--disable-recorder-output \
196 192
 	--disable-shout \

+ 3
- 3
sound/mpd/patches/210-support_raw_pcm_streams.patch Näytä tiedosto

@@ -1,6 +1,6 @@
1
---- a/src/decoder/FfmpegDecoderPlugin.cxx
2
-+++ b/src/decoder/FfmpegDecoderPlugin.cxx
3
-@@ -666,6 +666,7 @@ static const char *const ffmpeg_mime_typ
1
+--- a/src/decoder/plugins/FfmpegDecoderPlugin.cxx
2
++++ b/src/decoder/plugins/FfmpegDecoderPlugin.cxx
3
+@@ -765,6 +765,7 @@ static const char *const ffmpeg_mime_typ
4 4
  	"audio/qcelp",
5 5
  	"audio/vorbis",
6 6
  	"audio/vorbis+ogg",

+ 3
- 3
sound/mpd/patches/220-handle_slow_server_stream_startup.patch Näytä tiedosto

@@ -1,6 +1,6 @@
1
---- a/src/decoder/FfmpegDecoderPlugin.cxx
2
-+++ b/src/decoder/FfmpegDecoderPlugin.cxx
3
-@@ -376,6 +376,13 @@ ffmpeg_probe(Decoder *decoder, InputStre
1
+--- a/src/decoder/plugins/FfmpegDecoderPlugin.cxx
2
++++ b/src/decoder/plugins/FfmpegDecoderPlugin.cxx
3
+@@ -458,6 +458,13 @@ ffmpeg_probe(Decoder *decoder, InputStre
4 4
  
5 5
  	unsigned char buffer[BUFFER_SIZE];
6 6
  	size_t nbytes = decoder_read(decoder, is, buffer, BUFFER_SIZE);