Explorar el Código

Update minidlna to 1.1.3 version

medaved hace 10 años
padre
commit
5d65cd1df5
Se han modificado 2 ficheros con 12 adiciones y 19 borrados
  1. 11
    18
      multimedia/minidlna/Makefile
  2. 1
    1
      multimedia/minidlna/files/minidlna.config

+ 11
- 18
multimedia/minidlna/Makefile Ver fichero

@@ -13,12 +13,11 @@ PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@SF/minidlna
16
-PKG_MD5SUM:=879027192C89E5376CDD2AE2D1AA33B4
17
-
16
+PKG_MD5SUM:=879027192c89e5376cdd2ae2d1aa33b4
17
+PKG_MAINTAINER:=Knyazkov Dmitry <medavedik@gmail.com>
18 18
 PKG_BUILD_PARALLEL:=0
19 19
 PKG_BUILD_DEPENDS:=util-linux
20 20
 
21
-include $(INCLUDE_DIR)/kernel.mk
22 21
 include $(INCLUDE_DIR)/package.mk
23 22
 include $(INCLUDE_DIR)/nls.mk
24 23
 
@@ -38,7 +37,7 @@ define Package/minidlna/description
38 37
 endef
39 38
 
40 39
 define Package/minidlna/conffiles
41
-/etc/minidlna.conf
40
+/etc/config/minidlna
42 41
 endef
43 42
 
44 43
 TARGET_CPPFLAGS += \
@@ -64,16 +63,14 @@ MAKE_FLAGS +=\
64 63
 	LDFLAGS="$(TARGET_LDFLAGS)" \
65 64
 	ICONV_LIBS="-liconv $(if $(INTL_FULL),-lintl)" \
66 65
 
67
-MAKE_VARS +=\
68
-	PREFIX="$(STAGING_DIR)/usr" \
69
-	ICONV_PREFIX="$(ICONV_PREFIX)" \
70
-	INTL_PREFIX="$(INTL_PREFIX)" \
71
-	OS_NAME="OpenWrt Linux" \
72
-	OS_VERSION="$(LINUX_VERSION)" \
73
-	OS_URL="http://openwrt.org/" \
74
-	DB_PATH="/var/run/minidlna" \
75
-	LOG_PATH="/var/log" \
76
-
66
+CONFIGURE_ARGS +=\
67
+	--with-libiconv-prefix="$(ICONV_PREFIX)" \
68
+	--with-libintl-prefix="$(INTL_PREFIX)" \
69
+	--with-os-name="OpenWrt Linux" \
70
+	--with-os-version="$(LINUX_VERSION)" \
71
+	--with-os-url="http://openwrt.org/" \
72
+	--with-db-path="/var/run/minidlna" \
73
+	--with-log-path="/var/log" \
77 74
 
78 75
 define Package/minidlna/install
79 76
 	$(INSTALL_DIR) $(1)/usr/bin
@@ -84,8 +81,4 @@ define Package/minidlna/install
84 81
 	$(INSTALL_CONF) ./files/minidlna.config $(1)/etc/config/minidlna
85 82
 endef
86 83
 
87
-define Package/minidlna/conffiles
88
-/etc/config/minidlna
89
-endef
90
-
91 84
 $(eval $(call BuildPackage,minidlna))

+ 1
- 1
multimedia/minidlna/files/minidlna.config Ver fichero

@@ -1,5 +1,5 @@
1 1
 config minidlna config
2
-	option 'enabled' '0'
2
+	option 'enabled' '1'
3 3
 	option port '8200'
4 4
 	option interface 'br-lan'
5 5
 	option friendly_name 'OpenWrt DLNA Server'