Преглед изворни кода

jansson: pull version 2.7

Signed-off-by: Gergely Kiss <mail.gery@gmail.com>
Tested-by: Gergely Kiss <mail.gery@gmail.com>
Gergely Kiss пре 10 година
родитељ
комит
5e2f77242a
1 измењених фајлова са 52 додато и 0 уклоњено
  1. 52
    0
      libs/jansson/Makefile

+ 52
- 0
libs/jansson/Makefile Прегледај датотеку

@@ -0,0 +1,52 @@
1
+#
2
+# Copyright (C) 2011-2014 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=jansson
11
+PKG_VERSION:=2.7
12
+PKG_RELEASE:=1
13
+PKG_LICENSE:=MIT
14
+
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
16
+PKG_SOURCE_URL:=http://www.digip.org/jansson/releases/
17
+PKG_MD5SUM:=3a106a465bbb77637550b422f5b262ef
18
+
19
+PKG_INSTALL:=1
20
+PKG_BUILD_PARALLEL:=1
21
+
22
+include $(INCLUDE_DIR)/package.mk
23
+
24
+define Package/jansson
25
+  SECTION:=libs
26
+  CATEGORY:=Libraries
27
+  TITLE:=Jansson library
28
+  URL:=http://www.digip.org/jansson/
29
+  MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
30
+endef
31
+
32
+define Package/jansson/description
33
+  Jansson is a C library for encoding, decoding and manipulating JSON data
34
+endef
35
+
36
+TARGET_CFLAGS += $(FPIC)
37
+TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib -lm
38
+
39
+define Build/InstallDev
40
+	$(INSTALL_DIR) $(1)/usr/{lib,include}
41
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
42
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson* $(1)/usr/lib
43
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig
44
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
45
+endef
46
+
47
+define Package/jansson/install
48
+	$(INSTALL_DIR) $(1)/usr/lib
49
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjansson*so* $(1)/usr/lib/
50
+endef
51
+
52
+$(eval $(call BuildPackage,jansson))