Browse Source

libidn: make availible idn command line tool

Modified Makefile to make also availible the idn command line tool under
"Network"->"IP Addresses and Names"->"idn"

Signed-off-by: Christian Schoenebeck christian.schoenebeck@gmail.com
Christian Schoenebeck 10 years ago
parent
commit
5eabf48f21
1 changed files with 40 additions and 7 deletions
  1. 40
    7
      libs/libidn/Makefile

+ 40
- 7
libs/libidn/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2009-2014 OpenWrt.org
2
+# Copyright (C) 2009-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=libidn
11 11
 PKG_VERSION:=1.29
12
-PKG_RELEASE:=1
12
+PKG_RELEASE:=2
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=@GNU/libidn
@@ -17,7 +17,6 @@ PKG_MD5SUM:=2b67bb507207af379f9461e1307dc84b
17 17
 
18 18
 PKG_LICENSE:=GPL-2.0+ GPL-3.0+ LGPL-2.1+ LGPL-3.0+ Apache-2.0
19 19
 PKG_LICENSE_FILES:=COPYING COPYINGv2 COPYINGv3 COPYING.LESSERv2 COPYING.LESSERv3 java/LICENSE-2.0.txt
20
-PKG_MAINTAINER:=Marcel Denia <naoir@gmx.net>
21 20
 
22 21
 PKG_FIXUP:=autoreconf
23 22
 PKG_REMOVE_FILES:=GNUmakefile aclocal.m4
@@ -25,17 +24,45 @@ PKG_INSTALL:=1
25 24
 
26 25
 include $(INCLUDE_DIR)/package.mk
27 26
 
27
+define Package/idn/Default
28
+  SECTION:=net
29
+  CATEGORY:=Network
30
+  URL:=http://www.gnu.org/software/libidn/
31
+  MAINTAINER:=Marcel Denia <naoir@gmx.net>
32
+endef
33
+
34
+define Package/idn/Default/description
35
+  GNU Libidn is a fully documented implementation of the Stringprep,
36
+  Punycode and IDNA specifications. Libidn's purpose is to encode and
37
+  decode internationalized domain names.
38
+endef
39
+
40
+define Package/idn
41
+  $(call Package/idn/Default)
42
+  SUBMENU:=IP Addresses and Names
43
+  TITLE:=GNU IDN (Internationalized Domain Name) tool
44
+  DEPENDS:=+libidn
45
+endef
46
+
47
+define Package/idn/description
48
+$(call Package/idn/Default/description)
49
+
50
+  Command line tool using libidn
51
+
52
+endef
53
+
28 54
 define Package/libidn
55
+  $(call Package/idn/Default)
29 56
   SECTION:=libs
30 57
   CATEGORY:=Libraries
31 58
   TITLE:=Stringprep, Punycode and IDNA implementation
32
-  URL:=http://www.gnu.org/software/libidn/
33 59
 endef
34 60
 
35 61
 define Package/libidn/description
36
-  GNU Libidn is a fully documented implementation of the Stringprep,
37
-  Punycode and IDNA specifications. Libidn's purpose is to encode and
38
-  decode internationalized domain names.
62
+$(call Package/idn/Default/description)
63
+
64
+  Library only package
65
+
39 66
 endef
40 67
 
41 68
 TARGET_CFLAGS += $(FPIC)
@@ -54,9 +81,15 @@ define Build/InstallDev
54 81
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libidn.{a,so*} $(1)/usr/lib/
55 82
 endef
56 83
 
84
+define Package/idn/install
85
+	$(INSTALL_DIR) $(1)/usr/bin
86
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
87
+endef
88
+
57 89
 define Package/libidn/install
58 90
 	$(INSTALL_DIR) $(1)/usr/lib
59 91
 	$(CP) $(PKG_INSTALL_DIR)/usr/lib/libidn.so.* $(1)/usr/lib/
60 92
 endef
61 93
 
94
+$(eval $(call BuildPackage,idn))
62 95
 $(eval $(call BuildPackage,libidn))