浏览代码

python-crcmod: new package

Signed-off-by: Micke Prag <micke.prag@telldus.se>
Micke Prag 9 年前
父节点
当前提交
605e3ba441
共有 1 个文件被更改,包括 50 次插入0 次删除
  1. 50
    0
      lang/python-crcmod/Makefile

+ 50
- 0
lang/python-crcmod/Makefile 查看文件

@@ -0,0 +1,50 @@
1
+#
2
+# Copyright (C) 2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=python-crcmod
11
+PKG_VERSION:=1.7
12
+PKG_RELEASE:=1
13
+PKG_MAINTAINER:=Micke Prag <micke.prag@telldus.se>
14
+PKG_LICENSE:=MIT
15
+
16
+PKG_SOURCE:=crcmod-$(PKG_VERSION).tar.gz
17
+PKG_SOURCE_URL:=http://pypi.python.org/packages/source/c/crcmod/
18
+PKG_MD5SUM:=2d5b92117d958dcead94f9e17f54cd32
19
+
20
+PKG_BUILD_DIR:=$(BUILD_DIR)/crcmod-$(PKG_VERSION)
21
+PKG_BUILD_DEPENDS:=python
22
+
23
+include $(INCLUDE_DIR)/package.mk
24
+$(call include_mk, python-package.mk)
25
+
26
+define Package/python-crcmod
27
+  SUBMENU:=Python
28
+  SECTION:=lang
29
+  CATEGORY:=Languages
30
+  TITLE:=python-crcmod
31
+  URL:=http://crcmod.sourceforge.net/
32
+  DEPENDS:=+python-light
33
+endef
34
+
35
+define Package/python-crcmod/description
36
+  The software in this package is a Python module for generating objects that compute the Cyclic Redundancy Check (CRC). There is no attempt in this package to explain how the CRC works. There are a number of resources on the web that give a good explanation of the algorithms. Just do a Google search for "crc calculation" and browse till you find what you need. Another resource can be found in chapter 20 of the book "Numerical Recipes in C" by Press et. al.
37
+endef
38
+
39
+define Build/Compile
40
+	$(call Build/Compile/PyMod,,install --prefix="$(PKG_INSTALL_DIR)/usr")
41
+endef
42
+
43
+define Package/python-crcmod/install
44
+	$(INSTALL_DIR) $(1)$(PYTHON_PKG_DIR)
45
+	$(CP) \
46
+	    $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR)/* \
47
+	    $(1)$(PYTHON_PKG_DIR)
48
+endef
49
+
50
+$(eval $(call BuildPackage,python-crcmod))