Browse Source

gnutls: updated to 3.4.1

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 years ago
parent
commit
606d375b6f
2 changed files with 4 additions and 88 deletions
  1. 4
    4
      libs/gnutls/Makefile
  2. 0
    84
      libs/gnutls/patches/001-libopts-detection.patch

+ 4
- 4
libs/gnutls/Makefile View File

@@ -8,14 +8,14 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=gnutls
11
-PKG_VERSION:=3.4.0
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=3.4.1
12
+PKG_RELEASE:=1
13 13
 PKG_USE_MIPS16:=0
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
16 16
 PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.4
17
-PKG_MD5SUM:=aa015c2666b031044edfb01b01980d84
18
-PKG_FIXUP:=autoreconf gettext-version
17
+PKG_MD5SUM:=2d04f34fa25b45f9dcb9104c0394e12e
18
+#PKG_FIXUP:=autoreconf gettext-version
19 19
 PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
20 20
 PKG_LICENSE:=LGPLv2.1+
21 21
 

+ 0
- 84
libs/gnutls/patches/001-libopts-detection.patch View File

@@ -1,84 +0,0 @@
1
-diff --git a/configure.ac b/configure.ac
2
-index 7c454cd..185ebb6 100644
3
---- a/configure.ac
4
-+++ b/configure.ac
5
-@@ -64,7 +64,7 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
6
- ***
7
- *** autogen not found. Will not link against libopts.
8
- *** ]])
9
--    enable_local_libopts=yes
10
-+    included_libopts=yes
11
-   fi
12
- fi
13
- 
14
-@@ -523,7 +523,7 @@ fi
15
- 
16
- AM_CONDITIONAL(ENABLE_TROUSERS, test "$with_tpm" != "no")
17
- 
18
--enable_local_libopts=no
19
-+included_libopts=no
20
- if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
21
- 	LIBOPTS_CHECK([src/libopts])
22
- 	if test "$NEED_LIBOPTS_DIR" = "true";then
23
-@@ -540,15 +540,17 @@ if test "$enable_tools" != "no" || test "$enable_doc" != "no"; then
24
- 		if test -z "$missing_baks"; then
25
- 			AC_SUBST([AUTOGEN], [/bin/true])
26
- 		fi
27
--		enable_local_libopts=yes
28
-+		included_libopts=yes
29
- 	fi
30
- else
31
- 	# Need to ensure the relevant conditionals get set
32
- 	gl_STDNORETURN_H
33
- 	AM_CONDITIONAL([INSTALL_LIBOPTS],[false])
34
- 	AM_CONDITIONAL([NEED_LIBOPTS], [false])
35
-+	included_libopts=yes
36
- fi
37
--AM_CONDITIONAL(NEED_LIBOPTS, test "$enable_local_libopts" = "yes")
38
-+
39
-+AM_CONDITIONAL(NEED_LIBOPTS, test "$included_libopts" = "yes")
40
- 
41
- AC_CHECK_TYPE(ssize_t,
42
-   [
43
-@@ -896,7 +898,7 @@ AC_MSG_NOTICE([summary of build options:
44
-   Compiler:             ${CC}
45
-   CFlags:               ${CFLAGS}
46
-   Library types:        Shared=${enable_shared}, Static=${enable_static}
47
--  Local libopts:        ${enable_local_libopts}
48
-+  Local libopts:        ${included_libopts}
49
-   Local libtasn1:       ${included_libtasn1}
50
-   Use nettle-mini:      ${mini_nettle}
51
- ])
52
-diff --git a/src/Makefile.am b/src/Makefile.am
53
-index 4105ab6..b907249 100644
54
---- a/src/Makefile.am
55
-+++ b/src/Makefile.am
56
-@@ -30,13 +30,6 @@ if ENABLE_CRYWRAP
57
- SUBDIRS += crywrap
58
- endif
59
- 
60
--if NEED_LIBOPTS
61
--LIBOPTS = libopts/libopts.la
62
--SUBDIRS += libopts
63
--else
64
--LIBOPTS = $(LIBOPTS_LDADD)
65
--endif
66
--
67
- EXTRA_DIST = args-std.def
68
- 
69
- AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
70
-@@ -49,6 +42,14 @@ AM_CPPFLAGS = \
71
- 	-I$(srcdir)/../extra/includes	\
72
- 	$(LIBOPTS_CFLAGS)
73
- 
74
-+if NEED_LIBOPTS
75
-+LIBOPTS = libopts/libopts.la
76
-+SUBDIRS += libopts
77
-+AM_CPPFLAGS += -I$(srcdir)/libopts
78
-+else
79
-+LIBOPTS = $(LIBOPTS_LDADD)
80
-+endif
81
-+
82
- bin_PROGRAMS = psktool gnutls-cli-debug certtool
83
- if ENABLE_SRP
84
- bin_PROGRAMS += srptool