|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=pulseaudio
|
11
|
11
|
PKG_VERSION:=6.0
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
15
|
15
|
PKG_SOURCE_URL:=http://freedesktop.org/software/pulseaudio/releases/
|
|
@@ -27,12 +27,11 @@ PKG_INSTALL = 1
|
27
|
27
|
include $(INCLUDE_DIR)/package.mk
|
28
|
28
|
include $(INCLUDE_DIR)/nls.mk
|
29
|
29
|
|
30
|
|
-#TODO: split pulse into executable and library (or even better into several libraries since they're used as loadable modules, so not linked into)
|
31
|
30
|
define Package/pulseaudio/Default
|
32
|
31
|
SECTION:=sound
|
33
|
32
|
CATEGORY:=Sound
|
34
|
33
|
DEPENDS:=+libspeexdsp +libsndfile +libltdl +libpthread \
|
35
|
|
- +librt +alsa-lib +libjson +libopenssl +libwrap +libcap $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
|
34
|
+ +librt +alsa-lib +libopenssl +libwrap +libcap $(ICONV_DEPENDS) $(INTL_DEPENDS)
|
36
|
35
|
TITLE:=Network sound server
|
37
|
36
|
MAINTAINER:=Peter Wagner <tripolar@gmx.at>
|
38
|
37
|
URL:=http://www.pulseaudio.org
|
|
@@ -42,7 +41,7 @@ endef
|
42
|
41
|
|
43
|
42
|
define Package/pulseaudio-daemon
|
44
|
43
|
$(call Package/pulseaudio/Default)
|
45
|
|
- DEPENDS+=+libjson-c
|
|
44
|
+ DEPENDS+= +libjson-c
|
46
|
45
|
endef
|
47
|
46
|
|
48
|
47
|
define Package/pulseaudio/Default/description
|
|
@@ -63,7 +62,7 @@ endef
|
63
|
62
|
define Package/pulseaudio-tools
|
64
|
63
|
SECTION:=sound
|
65
|
64
|
CATEGORY:=Sound
|
66
|
|
- DEPENDS:=+libsndfile pulseaudio
|
|
65
|
+ DEPENDS:=+libsndfile +pulseaudio
|
67
|
66
|
TITLE:=Tools for Pulseaudio
|
68
|
67
|
URL:=http://www.pulseaudio.org
|
69
|
68
|
endef
|