Selaa lähdekoodia

libevdev: new package

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Daniel Golle 9 vuotta sitten
vanhempi
commit
615e26e446
1 muutettua tiedostoa jossa 57 lisäystä ja 0 poistoa
  1. 57
    0
      libs/libevdev/Makefile

+ 57
- 0
libs/libevdev/Makefile Näytä tiedosto

@@ -0,0 +1,57 @@
1
+#
2
+# Copyright (C) 2007-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=libevdev
11
+PKG_VERSION:=1.4.2
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
15
+PKG_SOURCE_URL:=http://www.freedesktop.org/software/libevdev/
16
+PKG_MD5SUM:=debfcd5153558eba25a8e71eb2534ae8
17
+
18
+PKG_LICENSE:=MIT
19
+PKG_LICENSE_FILES:=COPYING
20
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
21
+
22
+PKG_FIXUP:=autoreconf
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/libevdev
28
+  SECTION:=libs
29
+  CATEGORY:=Libraries
30
+  TITLE:=a wrapper library for evdev devices
31
+  URL:=http://www.freedesktop.org/wiki/Software/libevdev/
32
+endef
33
+
34
+define Package/libevdev/description
35
+  libevdev is a wrapper library for evdev devices. it moves the common
36
+  tasks when dealing with evdev devices into a library and provides a
37
+  library interface to the callers, thus avoiding erroneous ioctls, etc.
38
+
39
+  The eventual goal is that libevdev wraps all ioctls available to
40
+  evdev devices, thus making direct access unnecessary.
41
+endef
42
+
43
+define Build/InstallDev
44
+	$(INSTALL_DIR) $(1)/usr/include
45
+	$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
46
+	$(INSTALL_DIR) $(1)/usr/lib
47
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.{a,so*} $(1)/usr/lib/
48
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
49
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* $(1)/usr/lib/pkgconfig/
50
+endef
51
+
52
+define Package/libevdev/install
53
+	$(INSTALL_DIR) $(1)/usr/lib
54
+	$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
55
+endef
56
+
57
+$(eval $(call BuildPackage,libevdev))