浏览代码

ocserv: updated to 0.8.9

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Nikos Mavrogiannopoulos 10 年前
父节点
当前提交
6424128ae3

+ 3
- 3
net/ocserv/Makefile 查看文件

@@ -8,13 +8,13 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ocserv
11
-PKG_VERSION:=0.8.8
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=0.8.9
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_BUILD_DIR :=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
15 15
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
16 16
 PKG_SOURCE_URL :=ftp://ftp.infradead.org/pub/ocserv/
17
-PKG_MD5SUM:=d9b12a3fa976dfda3e4c0238173744e6
17
+PKG_MD5SUM:=cd935cc89bffac75c825e66ef71f6a73
18 18
 
19 19
 PKG_LICENSE:=GPLv2
20 20
 PKG_LICENSE_FILES:=COPYING

+ 0
- 55
net/ocserv/patches/001-use-define-_XOPEN_SOURCE-to-get-crypt.patch 查看文件

@@ -1,56 +0,0 @@
1
-From ef48fe731f8b43c58b9580a048d793a69bd5a903 Mon Sep 17 00:00:00 2001
2
-From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
3
-Date: Sat, 29 Nov 2014 19:44:03 +0100
4
-Subject: [PATCH] use define _XOPEN_SOURCE to get crypt()
5
-
6
----
7
- configure.ac     | 3 ++-
8
- src/auth/plain.c | 3 +++
9
- src/ocpasswd.c   | 3 +++
10
- 3 files changed, 8 insertions(+), 1 deletion(-)
11
-
12
-diff --git a/configure.ac b/configure.ac
13
-index 8bb0044..622929d 100644
14
---- a/configure.ac
15
-+++ b/configure.ac
16
-@@ -190,7 +190,8 @@ fi
17
- 
18
- gl_INIT
19
- 
20
--AC_LIB_HAVE_LINKFLAGS(crypt,, [#include <unistd.h>], [crypt(0,0);])
21
-+AC_LIB_HAVE_LINKFLAGS(crypt,, [#define _XOPEN_SOURCE
22
-+#include <unistd.h>], [crypt(0,0);])
23
- 
24
- AC_ARG_WITH(utmp,
25
-   AS_HELP_STRING([--without-utmp], [do not use libutil for utmp support]),
26
-diff --git a/src/auth/plain.c b/src/auth/plain.c
27
-index f429ef4..0e13241 100644
28
---- a/src/auth/plain.c
29
-+++ b/src/auth/plain.c
30
-@@ -22,6 +22,9 @@
31
- #include <stdlib.h>
32
- #include <string.h>
33
- #include <syslog.h>
34
-+#ifndef _XOPEN_SOURCE
35
-+# define _XOPEN_SOURCE
36
-+#endif
37
- #include <unistd.h>
38
- #include <vpn.h>
39
- #include <c-ctype.h>
40
-diff --git a/src/ocpasswd.c b/src/ocpasswd.c
41
-index 8b33d76..aced94a 100644
42
---- a/src/ocpasswd.c
43
-+++ b/src/ocpasswd.c
44
-@@ -23,6 +23,9 @@
45
- #include <string.h>
46
- #include <stdlib.h>
47
- #include <stdint.h>
48
-+#ifndef _XOPEN_SOURCE
49
-+# define _XOPEN_SOURCE
50
-+#endif
51
- #include <unistd.h>
52
- #include <gnutls/gnutls.h>
53
- #include <gnutls/crypto.h>	/* for random */
54
-2.1.3
55
-

+ 0
- 100
net/ocserv/patches/002-Notify-the-client-that-the-server-may-have-a-dynamic.patch 查看文件

@@ -1,101 +0,0 @@
1
-From cb9dcde3874441bf66d52b70ac8b0d6f6bb557d9 Mon Sep 17 00:00:00 2001
2
-From: Nikos Mavrogiannopoulos <nmav@gnutls.org>
3
-Date: Sun, 30 Nov 2014 11:30:08 +0100
4
-Subject: [PATCH] Notify the client that the server may have a dynamic DNS
5
- address
6
-
7
-That is send "X-CSTP-DynDNS: true", in CSTP headers if the
8
-server is configured as having a dynamic DNS address.
9
----
10
- doc/sample.config   | 5 +++++
11
- src/config.c        | 2 ++
12
- src/ocserv-args.def | 5 +++++
13
- src/vpn.h           | 1 +
14
- src/worker-vpn.c    | 7 +++++++
15
- 5 files changed, 20 insertions(+)
16
-
17
-diff --git a/doc/sample.config b/doc/sample.config
18
-index a39e573..e07e36a 100644
19
---- a/doc/sample.config
20
-+++ b/doc/sample.config
21
-@@ -51,6 +51,11 @@ max-same-clients = 2
22
- # hostname.
23
- #listen-host = [IP|HOSTNAME]
24
- 
25
-+# When the server has a dynamic DNS address (that may change),
26
-+# should set that to true to ask the client to resolve again on
27
-+# reconnects.
28
-+#listen-host-is-dyndns = true
29
-+
30
- # TCP and UDP port number
31
- tcp-port = 443
32
- udp-port = 443
33
-diff --git a/src/config.c b/src/config.c
34
-index 2721a45..0b7e029 100644
35
---- a/src/config.c
36
-+++ b/src/config.c
37
-@@ -60,6 +60,7 @@ static struct cfg_options available_options[] = {
38
- 	{ .name = "custom-header", .type = OPTION_MULTI_LINE, .mandatory = 0 },
39
- 	{ .name = "split-dns", .type = OPTION_MULTI_LINE, .mandatory = 0 },
40
- 	{ .name = "listen-host", .type = OPTION_STRING, .mandatory = 0 },
41
-+	{ .name = "listen-host-is-dyndns", .type = OPTION_BOOLEAN, .mandatory = 0 },
42
- 	{ .name = "tcp-port", .type = OPTION_NUMERIC, .mandatory = 0 },
43
- 	{ .name = "udp-port", .type = OPTION_NUMERIC, .mandatory = 0 },
44
- 	{ .name = "keepalive", .type = OPTION_NUMERIC, .mandatory = 0 },
45
-@@ -403,6 +404,7 @@ unsigned force_cert_auth;
46
- 	 * reload_cfg_file();
47
- 	 */
48
- 	READ_STRING("listen-host", config->name);
49
-+	READ_TF("listen-host-is-dyndns", config->is_dyndns, 0);
50
- 
51
- 	READ_NUMERIC("tcp-port", config->port);
52
- 	READ_NUMERIC("udp-port", config->udp_port);
53
-diff --git a/src/ocserv-args.def b/src/ocserv-args.def
54
-index cdc60bd..146e59a 100644
55
---- a/src/ocserv-args.def
56
-+++ b/src/ocserv-args.def
57
-@@ -126,6 +126,11 @@ max-same-clients = 2
58
- # hostname.
59
- #listen-host = [IP|HOSTNAME]
60
- 
61
-+# When the server has a dynamic DNS address (that may change),
62
-+# should set that to true to ask the client to resolve again on
63
-+# reconnects.
64
-+#listen-host-is-dyndns = true
65
-+
66
- # TCP and UDP port number
67
- tcp-port = 3333
68
- udp-port = 3333
69
-diff --git a/src/vpn.h b/src/vpn.h
70
-index a460370..03721e1 100644
71
---- a/src/vpn.h
72
-+++ b/src/vpn.h
73
-@@ -188,6 +188,7 @@ struct cfg_st {
74
- 	char *name; /* server name */
75
- 	unsigned int port;
76
- 	unsigned int udp_port;
77
-+	unsigned int is_dyndns;
78
- 	char* unix_conn_file;
79
- 
80
- 	char *pin_file;
81
-diff --git a/src/worker-vpn.c b/src/worker-vpn.c
82
-index 364cbff..4cb5d99 100644
83
---- a/src/worker-vpn.c
84
-+++ b/src/worker-vpn.c
85
-@@ -1650,6 +1650,13 @@ static int connect_handler(worker_st * ws)
86
- 		     "X-CSTP-Smartcard-Removal-Disconnect: true\r\n");
87
- 	SEND_ERR(ret);
88
- 
89
-+	if (ws->config->is_dyndns != 0) {
90
-+		ret =
91
-+		    cstp_puts(ws,
92
-+			     "X-CSTP-DynDNS: true\r\n");
93
-+		SEND_ERR(ret);
94
-+	}
95
-+
96
- 	if (ws->config->rekey_time > 0) {
97
- 		unsigned method;
98
- 
99
-2.1.3
100
-