Ver código fonte

xinetd: fix musl compatibility

Pass HAVE_RLIM_T via TARGET_CPPFLAGS since configure uses that define
but never actually declares it.

Without doing that, `config.h` tries to declare `rlim_t` itself which
leads to `config.h:126:16: error: 'long long long' is too long for GCC`
with musl on at least x86_64.

Also refresh patches while we're at it.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
Jo-Philipp Wich 9 anos atrás
pai
commit
644ae71ebc
2 arquivos alterados com 5 adições e 4 exclusões
  1. 3
    2
      net/xinetd/Makefile
  2. 2
    2
      net/xinetd/patches/004-ident-bind.patch

+ 3
- 2
net/xinetd/Makefile Ver arquivo

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2006-2014 OpenWrt.org
2
+# Copyright (C) 2006-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=xinetd
11 11
 PKG_VERSION:=2.3.15
12
-PKG_RELEASE:=3
12
+PKG_RELEASE:=4
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.xinetd.org
@@ -42,6 +42,7 @@ define Package/xinetd/conffiles
42 42
 endef
43 43
 
44 44
 TARGET_CFLAGS += -DNO_RPC
45
+TARGET_CPPFLAGS += -DHAVE_RLIM_T
45 46
 
46 47
 CONFIGURE_ARGS += \
47 48
 	--without-libwrap \

+ 2
- 2
net/xinetd/patches/004-ident-bind.patch Ver arquivo

@@ -10,7 +10,7 @@ Reviewed-By: Adam Tkac <atkac@redhat.com>
10 10
 #diff -up xinetd-2.3.14/xinetd/ident.c.orig xinetd-2.3.14/xinetd/ident.c
11 11
 --- a/xinetd/ident.c
12 12
 +++ b/xinetd/ident.c
13
-@@ -97,7 +98,13 @@ idresult_e log_remote_user( const struct
13
+@@ -97,7 +97,13 @@ idresult_e log_remote_user( const struct
14 14
     }
15 15
  
16 16
     CLEAR( sin_contact );
@@ -25,7 +25,7 @@ Reviewed-By: Adam Tkac <atkac@redhat.com>
25 25
     sin_contact = sin_remote;
26 26
     memcpy( &sin_bind, &sin_local, sizeof(sin_bind) ) ;
27 27
     local_port = 0;
28
-@@ -121,7 +128,13 @@ idresult_e log_remote_user( const struct
28
+@@ -127,7 +133,13 @@ idresult_e log_remote_user( const struct
29 29
        msg( LOG_ERR, func, "socket creation: %m" ) ;
30 30
        return( IDR_ERROR ) ;
31 31
     }