|
@@ -0,0 +1,75 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006-2011 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=libupnp
|
|
11
|
+PKG_VERSION:=1.6.18
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
15
|
+PKG_SOURCE_URL:=@SF/pupnp
|
|
16
|
+PKG_MD5SUM:=11c6484fd2e2927bf3b8d8108407ca56
|
|
17
|
+
|
|
18
|
+PKG_FIXUP:=autoreconf
|
|
19
|
+PKG_INSTALL:=1
|
|
20
|
+
|
|
21
|
+include $(INCLUDE_DIR)/package.mk
|
|
22
|
+
|
|
23
|
+define Package/libupnp/Default
|
|
24
|
+ SECTION:=libs
|
|
25
|
+ CATEGORY:=Libraries
|
|
26
|
+ URL:=http://pupnp.sourceforge.net/
|
|
27
|
+endef
|
|
28
|
+
|
|
29
|
+define Package/libupnp
|
|
30
|
+ $(call Package/libupnp/Default)
|
|
31
|
+ DEPENDS:=+libpthread
|
|
32
|
+ TITLE:=UPnP SDK library
|
|
33
|
+ MENU:=1
|
|
34
|
+endef
|
|
35
|
+
|
|
36
|
+define Package/libupnp/description
|
|
37
|
+The portable SDK for UPnP Devices (libupnp) provides developers with an API and
|
|
38
|
+open source code for building control points, devices, and bridges that are
|
|
39
|
+compliant with Version 1.0 of the Universal Plug and Play Device Architecture
|
|
40
|
+Specification.
|
|
41
|
+endef
|
|
42
|
+
|
|
43
|
+define Package/libupnp-sample
|
|
44
|
+ $(call Package/libupnp/Default)
|
|
45
|
+ DEPENDS:=libupnp
|
|
46
|
+ TITLE:=UPnP sample applications
|
|
47
|
+endef
|
|
48
|
+
|
|
49
|
+define Package/libupnp-sample/description
|
|
50
|
+TVcontrolpoint & tvdevice sample applications run inside /etc/upnp-tvdevice/
|
|
51
|
+endef
|
|
52
|
+
|
|
53
|
+define Build/InstallDev
|
|
54
|
+ $(INSTALL_DIR) $(1)/usr/include
|
|
55
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/include/upnp $(1)/usr/include/
|
|
56
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
57
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.{a,so*,la} $(1)/usr/lib/
|
|
58
|
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
59
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libupnp.pc $(1)/usr/lib/pkgconfig/
|
|
60
|
+endef
|
|
61
|
+
|
|
62
|
+define Package/libupnp/install
|
|
63
|
+ $(INSTALL_DIR) $(1)/usr/lib
|
|
64
|
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{ixml,threadutil,upnp}.so.* $(1)/usr/lib/
|
|
65
|
+endef
|
|
66
|
+
|
|
67
|
+define Package/libupnp-sample/install
|
|
68
|
+ $(INSTALL_DIR) $(1)/usr/bin
|
|
69
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/upnp/sample/.libs/* $(1)/usr/bin
|
|
70
|
+ $(INSTALL_DIR) $(1)/etc/upnp-tvdevice/web
|
|
71
|
+ $(INSTALL_DATA) $(PKG_BUILD_DIR)/upnp/sample/web/* $(1)/etc/upnp-tvdevice
|
|
72
|
+endef
|
|
73
|
+
|
|
74
|
+$(eval $(call BuildPackage,libupnp))
|
|
75
|
+$(eval $(call BuildPackage,libupnp-sample))
|