Bläddra i källkod

radicale: fixed hotplug and init script

* fixed hotplug script (not restarting on "ifup")
* fixed init script (not stopping in 1 second)
* fixed PKG_MAINTAINER string
* removing not needed comments in config file

Signed-off-by: Christian Schoenebeck <christian.schoenebeck@gmail.com>
Christian Schoenebeck 9 år sedan
förälder
incheckning
65fb23d515

+ 2
- 2
net/radicale/Makefile Visa fil

@@ -8,8 +8,8 @@ include $(TOPDIR)/rules.mk
8 8
 
9 9
 PKG_NAME:=radicale
10 10
 PKG_VERSION:=0.10
11
-PKG_RELEASE:=1
12
-PKG_MAINTAINER:=Christian Schoenebeck <chris5560@web.de>
11
+PKG_RELEASE:=2
12
+PKG_MAINTAINER:=Christian Schoenebeck <christian.schoenebeck@gmail.com>
13 13
 
14 14
 PKG_LICENSE:=GPL-3.0
15 15
 PKG_LICENSE_FILES:=COPYING

+ 0
- 2
net/radicale/files/radicale.config Visa fil

@@ -71,7 +71,6 @@ config setting 'auth'
71 71
 	# Value: None | htpasswd | IMAP | LDAP | PAM | courier | http | remote_user | custom
72 72
 	# Default: None
73 73
 	# if setting 'htpasswd' the file /etc/radicale/users is used (hardcoded)
74
-#	option type 'htpasswd'
75 74
 
76 75
 	# Htpasswd encryption method
77 76
 	# Value: plain | sha1 | ssha | crypt
@@ -98,7 +97,6 @@ config setting 'rights'
98 97
 	# Value: None | authenticated | owner_only | owner_write | from_file | custom
99 98
 	# Default: None
100 99
 	# if setting 'from_file' the file /etc/radicale/rights is used (hardcoded)
101
-#	option	type	'from_file'
102 100
 
103 101
 	# Custom rights handler
104 102
 #	option custom_handler ''

+ 1
- 1
net/radicale/files/radicale.hotplug Visa fil

@@ -3,7 +3,7 @@
3 3
 # only (re-)start on ifup
4 4
 [ "$ACTION" = "ifup" ] || exit 0
5 5
 
6
-_PID=$(ps | grep '[p]ython.*[r]adicale' 2>/dev/null | awk '{print \$1}')
6
+_PID=$(ps | grep '[p]ython.*[r]adicale' 2>/dev/null | awk '{print $1}')
7 7
 kill -1 $_PID 2>/dev/null
8 8
 if [ $? -eq 0 ]; then
9 9
 	# only restart if already running

+ 1
- 1
net/radicale/files/radicale.init Visa fil

@@ -208,7 +208,7 @@ stop() {
208 208
 	local _PID=$(eval "$PGREP")
209 209
 	[ -z "$_PID" ] && return 0	# not running
210 210
 	kill -15 $_PID 2>/dev/null
211
-	sleep 1			# give time to shutdown
211
+	sleep 3			# give time to shutdown
212 212
 	local _tmp=$(eval "$PGREP")
213 213
 	if [ -z "$_tmp" ]; then
214 214
 		logger -p user.notice -t "radicale[$_PID]" "Service shutdown successfully"