Browse Source

ffmpeg: Update to 2.4.4

Drop fminf patch; fminf emulation is no longer included upstream.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>
Ian Leonard 10 years ago
parent
commit
665cd72e82

+ 2
- 2
multimedia/ffmpeg/Makefile View File

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=ffmpeg
11
-PKG_VERSION:=2.4.2
11
+PKG_VERSION:=2.4.4
12 12
 PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
15 15
 PKG_SOURCE_URL:=http://ffmpeg.org/releases/
16
-PKG_MD5SUM:=9e6163b09b7b9331b834d80874c2c0ff
16
+PKG_MD5SUM:=7e2819c71484ffba1ba1a91dd5285643
17 17
 PKG_MAINTAINER:=Ted Hess <thess@kitschensync.net>
18 18
 
19 19
 PKG_LICENSE:=LGPL-2.1+ GPL-2+ LGPL-3

+ 0
- 18
multimedia/ffmpeg/patches/010-remove_unused_fminf_definition.patch View File

@@ -1,18 +0,0 @@
1
---- a/libavutil/libm.h
2
-+++ b/libavutil/libm.h
3
-@@ -82,6 +82,7 @@ static av_always_inline float cbrtf(floa
4
- #define exp2f(x) ((float)exp2(x))
5
- #endif /* HAVE_EXP2F */
6
- 
7
-+/* ---------- BROKEN: Defined in math.h but not present in uClibc 0.9.33.2 
8
- #if !HAVE_FMINF
9
- #undef fminf
10
- static av_always_inline av_const float fminf(float x, float y)
11
-@@ -91,6 +92,7 @@ static av_always_inline av_const float f
12
-     return x > y ? y : (x == x ? x : y);
13
- }
14
- #endif
15
-+------------------------------------------------------------------------- */
16
- 
17
- #if !HAVE_ISINF
18
- static av_always_inline av_const int isinf(float x)