Pārlūkot izejas kodu

haproxy: fixes from upstream

[PATCH 4/5] BUG/MINOR: http: base32+src should use the big endian
[PATCH 5/5] BUG/MEDIUM: connection: fix memory corruption when

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
Thomas Heil 10 gadus atpakaļ
vecāks
revīzija
6785138bca

+ 1
- 1
net/haproxy/Makefile Parādīt failu

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=haproxy
12 12
 PKG_VERSION:=1.5.2
13
-PKG_RELEASE:=03
13
+PKG_RELEASE:=05
14 14
 PKG_SOURCE:=haproxy-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.5/src/
16 16
 PKG_MD5SUM:=e854fed32ea751d6db7f366cb910225a

+ 35
- 0
net/haproxy/patches/0004-BUG-MINOR-http-base32-src-should-use-the-big-endian-.patch Parādīt failu

@@ -0,0 +1,35 @@
1
+From 0dff81c6a5876172bc1d4725a7a07fddd9d1f369 Mon Sep 17 00:00:00 2001
2
+From: Willy Tarreau <w@1wt.eu>
3
+Date: Tue, 15 Jul 2014 21:34:06 +0200
4
+Subject: [PATCH 4/5] BUG/MINOR: http: base32+src should use the big endian
5
+ version of base32
6
+
7
+We're using the internal memory representation of base32 here, which is
8
+wrong since these data might be exported to headers for logs or be used
9
+to stick to a server and replicated to other peers. Let's convert base32
10
+to big endian (network representation) when building the binary block.
11
+
12
+This mistake is also present in 1.5, it would be better to backport it.
13
+(cherry picked from commit 5ad6e1dc09f0a85aabf86f154b1817b9ebffb568)
14
+---
15
+ src/proto_http.c | 4 ++--
16
+ 1 file changed, 2 insertions(+), 2 deletions(-)
17
+
18
+diff --git a/src/proto_http.c b/src/proto_http.c
19
+index 94afed7..b7ed85d 100644
20
+--- a/src/proto_http.c
21
++++ b/src/proto_http.c
22
+@@ -10358,8 +10358,8 @@ smp_fetch_base32_src(struct proxy *px, struct session *l4, void *l7, unsigned in
23
+ 		return 0;
24
+ 
25
+ 	temp = get_trash_chunk();
26
+-	memcpy(temp->str + temp->len, &smp->data.uint, sizeof(smp->data.uint));
27
+-	temp->len += sizeof(smp->data.uint);
28
++	*(unsigned int *)temp->str = htonl(smp->data.uint);
29
++	temp->len += sizeof(unsigned int);
30
+ 
31
+ 	switch (cli_conn->addr.from.ss_family) {
32
+ 	case AF_INET:
33
+-- 
34
+1.8.5.5
35
+

+ 42
- 0
net/haproxy/patches/0005-BUG-MEDIUM-connection-fix-memory-corruption-when-bui.patch Parādīt failu

@@ -0,0 +1,42 @@
1
+From 66dbae025876a65c81ae3c4011e3aa3b630b42f7 Mon Sep 17 00:00:00 2001
2
+From: Dave McCowan <11235david@gmail.com>
3
+Date: Thu, 17 Jul 2014 14:34:01 -0400
4
+Subject: [PATCH 5/5] BUG/MEDIUM: connection: fix memory corruption when
5
+ building a proxy v2 header
6
+
7
+Use temporary trash chunk, instead of global trash chunk in
8
+make_proxy_line_v2() to avoid memory overwrite.
9
+
10
+This fix must also be backported to 1.5.
11
+(cherry picked from commit 77d1f0143e210c13ee8ec6aaf6b3150fa4ce6c5b)
12
+---
13
+ src/connection.c | 6 ++++--
14
+ 1 file changed, 4 insertions(+), 2 deletions(-)
15
+
16
+diff --git a/src/connection.c b/src/connection.c
17
+index 20a911b..3435b1a 100644
18
+--- a/src/connection.c
19
++++ b/src/connection.c
20
+@@ -622,6 +622,7 @@ int make_proxy_line_v2(char *buf, int buf_len, struct server *srv, struct connec
21
+ 	char *value = NULL;
22
+ 	struct tlv_ssl *tlv;
23
+ 	int ssl_tlv_len = 0;
24
++	struct chunk *cn_trash;
25
+ #endif
26
+ 
27
+ 	if (buf_len < PP2_HEADER_LEN)
28
+@@ -682,8 +683,9 @@ int make_proxy_line_v2(char *buf, int buf_len, struct server *srv, struct connec
29
+ 				tlv->verify = htonl(ssl_sock_get_verify_result(remote));
30
+ 			}
31
+ 			if (srv->pp_opts & SRV_PP_V2_SSL_CN) {
32
+-				if (ssl_sock_get_remote_common_name(remote, &trash) > 0) {
33
+-					tlv_len = make_tlv(&buf[ret+ssl_tlv_len], (buf_len - ret - ssl_tlv_len), PP2_TYPE_SSL_CN, trash.len, trash.str);
34
++				cn_trash = get_trash_chunk();
35
++				if (ssl_sock_get_remote_common_name(remote, &cn_trash) > 0) {
36
++					tlv_len = make_tlv(&buf[ret+ssl_tlv_len], (buf_len - ret - ssl_tlv_len), PP2_TYPE_SSL_CN, cn_trash->len, cn_trash->str);
37
+ 					ssl_tlv_len += tlv_len;
38
+ 				}
39
+ 			}
40
+-- 
41
+1.8.5.5
42
+