|
@@ -0,0 +1,45 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2006 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PKG_NAME:=horst
|
|
11
|
+PKG_VERSION:=4.0
|
|
12
|
+PKG_RELEASE:=1
|
|
13
|
+
|
|
14
|
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-git.tar.gz
|
|
15
|
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
16
|
+PKG_SOURCE_URL:=git://br1.einfach.org/horst
|
|
17
|
+PKG_SOURCE_PROTO:=git
|
|
18
|
+PKG_SOURCE_VERSION:=version-4.0
|
|
19
|
+
|
|
20
|
+PKG_BUILD_PARALLEL:=1
|
|
21
|
+
|
|
22
|
+include $(INCLUDE_DIR)/package.mk
|
|
23
|
+
|
|
24
|
+define Package/horst
|
|
25
|
+ SECTION:=net
|
|
26
|
+ CATEGORY:=Network
|
|
27
|
+ SUBMENU:=wireless
|
|
28
|
+ DEPENDS:=+libncurses
|
|
29
|
+ MAINTAINER:=Bruno Randolf <br1@einfach.org>
|
|
30
|
+ TITLE:=Highly Optimized 802.11 Radio Scanning Tool
|
|
31
|
+ URL:=http://br1.einfach.org/tech/horst/
|
|
32
|
+endef
|
|
33
|
+
|
|
34
|
+define Package/horst/description
|
|
35
|
+ [horst] is a scanning and analysis tool for 802.11 wireless networks
|
|
36
|
+ and especially IBSS (ad-hoc) mode and mesh networks (OLSR).
|
|
37
|
+endef
|
|
38
|
+
|
|
39
|
+define Package/horst/install
|
|
40
|
+ $(INSTALL_DIR) $(1)/usr/sbin
|
|
41
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/horst $(1)/usr/sbin/
|
|
42
|
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/horst.sh $(1)/usr/sbin/
|
|
43
|
+endef
|
|
44
|
+
|
|
45
|
+$(eval $(call BuildPackage,horst))
|