Browse Source

umurmur: Update to 0.2.16. Also fix build breakage since PolarSSL/MbedTLS's version module was disabled.

Signed-off-by: Martin Johansson <martin@fatbob.nu>
Martin Johansson 9 years ago
parent
commit
6c004eb0a2

+ 4
- 4
net/umurmur/Makefile View File

@@ -1,5 +1,5 @@
1 1
 #
2
-# Copyright (C) 2009-2014 OpenWrt.org
2
+# Copyright (C) 2009-2015 OpenWrt.org
3 3
 #
4 4
 # This is free software, licensed under the GNU General Public License v2.
5 5
 # See /LICENSE for more information.
@@ -7,14 +7,14 @@
7 7
 include $(TOPDIR)/rules.mk
8 8
 
9 9
 PKG_NAME:=umurmur
10
-PKG_VERSION:=0.2.15
10
+PKG_VERSION:=0.2.16
11 11
 PKG_RELEASE:=1
12 12
 
13 13
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
14 14
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
15
-PKG_SOURCE_URL:=git://github.com/fatbob313/umurmur.git
15
+PKG_SOURCE_URL:=git://github.com/umurmur/umurmur.git
16 16
 PKG_SOURCE_PROTO:=git
17
-PKG_SOURCE_VERSION:=f66c0c3d630aaff1c4d589bc4d884067f00b6529
17
+PKG_SOURCE_VERSION:=0.2.16
18 18
 
19 19
 PKG_INSTALL:=1
20 20
 PKG_FIXUP:=autoreconf

+ 17
- 0
net/umurmur/patches/10-Add-compile-time-check-for-POLARSSL_VERSION_FEATURES.patch View File

@@ -0,0 +1,17 @@
1
+diff --git a/src/ssli_polarssl.c b/src/ssli_polarssl.c
2
+index a36ccb6..167637b 100644
3
+--- a/src/ssli_polarssl.c
4
++++ b/src/ssli_polarssl.c
5
+@@ -225,8 +225,12 @@ void SSLi_init(void)
6
+ 	    Log_fatal("Cannot open /dev/urandom");
7
+ #endif
8
+ 
9
++#ifdef POLARSSL_VERSION_FEATURES
10
+     version_get_string(verstring);
11
+     Log_info("PolarSSL library version %s initialized", verstring);
12
++#else
13
++    Log_info("PolarSSL library initialized");
14
++#endif
15
+ }
16
+ 
17
+ void SSLi_deinit(void)