Browse Source

openvswitch: fix kernel 4.4 patch for pre-4.4 kernels

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
Alexandru Ardelean 8 years ago
parent
commit
6cb655eba8
2 changed files with 2 additions and 2 deletions
  1. 1
    1
      net/openvswitch/Makefile
  2. 1
    1
      net/openvswitch/patches/0011-kernel-4-4-support.patch

+ 1
- 1
net/openvswitch/Makefile View File

@@ -12,7 +12,7 @@ include $(INCLUDE_DIR)/kernel.mk
12 12
 
13 13
 PKG_NAME:=openvswitch
14 14
 
15
-PKG_RELEASE:=6
15
+PKG_RELEASE:=7
16 16
 PKG_VERSION:=2.5.0
17 17
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
18 18
 PKG_LICENSE:=Apache-2.0

+ 1
- 1
net/openvswitch/patches/0011-kernel-4-4-support.patch View File

@@ -129,8 +129,8 @@ index cd87bcc..b749301 100644
129 129
  	unsigned int mtu = ip_skb_dst_mtu(skb);
130 130
  	struct iphdr *iph = ip_hdr(skb);
131 131
  	struct rtable *rt = skb_rtable(skb);
132
-+	NET_DECLARE_INIT(net, dev_net(dev));
133 132
  	struct net_device *dev = rt->dst.dev;
133
++	NET_DECLARE_INIT(net, dev_net(dev));
134 134
  
135 135
  	if (unlikely(((iph->frag_off & htons(IP_DF)) && !skb->ignore_df) ||
136 136
 @@ -102,7 +115,7 @@ static inline int rpl_ip_do_fragment(struct sock *sk, struct sk_buff *skb,