|
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
9
|
9
|
|
10
|
10
|
PKG_NAME:=socat
|
11
|
11
|
PKG_VERSION:=1.7.2.4
|
12
|
|
-PKG_RELEASE:=1
|
|
12
|
+PKG_RELEASE:=2
|
13
|
13
|
|
14
|
14
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
15
|
15
|
PKG_SOURCE_URL:=http://www.dest-unreach.org/socat/download
|
|
@@ -50,6 +50,10 @@ config SOCAT_SSL
|
50
|
50
|
Implements SSL support in socat (using libopenssl).
|
51
|
51
|
endef
|
52
|
52
|
|
|
53
|
+define Package/socat/conffiles
|
|
54
|
+/etc/config/socat
|
|
55
|
+endef
|
|
56
|
+
|
53
|
57
|
CONFIGURE_ARGS += \
|
54
|
58
|
--disable-libwrap \
|
55
|
59
|
--disable-readline \
|
|
@@ -68,6 +72,10 @@ CONFIGURE_VARS += \
|
68
|
72
|
define Package/socat/install
|
69
|
73
|
$(INSTALL_DIR) $(1)/usr/bin
|
70
|
74
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/socat $(1)/usr/bin/
|
|
75
|
+ $(INSTALL_DIR) $(1)/etc/config
|
|
76
|
+ $(INSTALL_CONF) ./files/socat.config $(1)/etc/config/socat
|
|
77
|
+ $(INSTALL_DIR) $(1)/etc/init.d
|
|
78
|
+ $(INSTALL_BIN) ./files/socat.init $(1)/etc/init.d/socat
|
71
|
79
|
endef
|
72
|
80
|
|
73
|
81
|
$(eval $(call BuildPackage,socat))
|