Ver código fonte

upmpdcli: Bump version to 0.11.0

upmpdcli 0.11 mainly improves on the Songcast support, in
complement with the changes in sc2mpd. Especially, it now
includes an utility (scctl) and web interface to set up
multi-room Songcast.

Signed-off-by: Petko Bordjukov <bordjukov@gmail.com>
Petko Bordjukov 9 anos atrás
pai
commit
6e96e4532a
2 arquivos alterados com 32 adições e 4 exclusões
  1. 17
    0
      sound/upmpdcli/Config.in
  2. 15
    4
      sound/upmpdcli/Makefile

+ 17
- 0
sound/upmpdcli/Config.in Ver arquivo

@@ -0,0 +1,17 @@
1
+config PACKAGE_UPMPDCLI_SCCTL
2
+	bool "scctl command for configuring SongCast receivers"
3
+	default no
4
+	depends on PACKAGE_upmpdcli
5
+	help
6
+		Installs the scctl command. See the following link for more info: 
7
+		http://www.lesbonscomptes.com/upmpdcli/scmulti.html
8
+
9
+config PACKAGE_UPMPDCLI_SC_WEB_INTERFACE
10
+	bool "SongCast web server and associated files (depends on python)"
11
+	default no
12
+	depends on PACKAGE_upmpdcli
13
+	select PACKAGE_python
14
+	select PACKAGE_UPMPDCLI_SCCTL
15
+	help
16
+		Installs the SongCast web interface and web server. See the following
17
+		link for more info: http://www.lesbonscomptes.com/upmpdcli/scmulti.html

+ 15
- 4
sound/upmpdcli/Makefile Ver arquivo

@@ -8,12 +8,12 @@
8 8
 include $(TOPDIR)/rules.mk
9 9
 
10 10
 PKG_NAME:=upmpdcli
11
-PKG_VERSION:=0.9.0
12
-PKG_RELEASE:=2
11
+PKG_VERSION:=0.11.0
12
+PKG_RELEASE:=1
13 13
 
14 14
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15 15
 PKG_SOURCE_URL:=http://www.lesbonscomptes.com/upmpdcli/downloads
16
-PKG_MD5SUM:=0e7b86037f19ea3a08067409af6f6902
16
+PKG_MD5SUM:=40eb2a1988ca367a690fb2506e0f73c1
17 17
 PKG_MAINTAINER:=Petko Bordjukov <bordjukov@gmail.com>
18 18
 PKG_LICENSE:=GPL-2.0
19 19
 PKG_LICENSE_FILES:=COPYING
@@ -29,12 +29,17 @@ define Package/upmpdcli
29 29
   DEPENDS+= +libupnpp +libmpdclient
30 30
   TITLE:=A UPnP front-end to MPD, the Music Player Daemon
31 31
   USERID:=upmpdcli=89:upmpdcli=89
32
+  MENU:=1
32 33
 endef
33 34
 
34 35
 define Package/upmpdcli/description
35 36
 upmpdcli implements an UPnP Media Renderer, using MPD to perform the real work.
36 37
 endef
37 38
 
39
+define Package/upmpdcli/config
40
+	source "$(SOURCE)/Config.in"
41
+endef
42
+
38 43
 define Package/upmpdcli/install
39 44
 	$(INSTALL_DIR) $(1)/etc
40 45
 	$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/upmpdcli.conf $(1)/etc/
@@ -42,8 +47,14 @@ define Package/upmpdcli/install
42 47
 	$(INSTALL_CONF) ./files/upmpdcli.config $(1)/etc/config/upmpdcli
43 48
 	$(INSTALL_DIR) $(1)/usr/bin
44 49
 	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/upmpdcli $(1)/usr/bin/
50
+ifeq ($(CONFIG_PACKAGE_UPMPDCLI_SCCTL),y)
51
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scctl $(1)/usr/bin/
52
+endif
45 53
 	$(INSTALL_DIR) $(1)/usr/share/upmpdcli
46
-	$(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/upmpdcli/* $(1)/usr/share/upmpdcli/
54
+ifneq ($(CONFIG_PACKAGE_UPMPDCLI_SC_WEB_INTERFACE),y)
55
+	$(RM) -rf $(PKG_INSTALL_DIR)/usr/share/upmpdcli/web
56
+endif
57
+	$(CP) -r $(PKG_INSTALL_DIR)/usr/share/upmpdcli $(1)/usr/share/
47 58
 	$(INSTALL_DATA) ./files/upmpdcli.png $(1)/usr/share/upmpdcli/
48 59
 	$(INSTALL_DIR) $(1)/etc/init.d
49 60
 	$(INSTALL_BIN) ./files/upmpdcli.init $(1)/etc/init.d/upmpdcli