浏览代码

ibrdtn: Disable dependency on glib-2.0 library

Since the current release of the package does not provide a
configure option to disable this dependency, a patch is necessary
to add this option.

Signed-off-by: Johannes Morgenroth <morgenroth@ibr.cs.tu-bs.de>
Johannes Morgenroth 10 年前
父节点
当前提交
719ed2b98b
共有 2 个文件被更改,包括 35 次插入1 次删除
  1. 2
    1
      libs/ibrdtn/Makefile
  2. 33
    0
      libs/ibrdtn/patches/100-add_configure_options.patch

+ 2
- 1
libs/ibrdtn/Makefile 查看文件

@@ -34,7 +34,8 @@ define Package/ibrdtn/description
34 34
 endef
35 35
 
36 36
 CONFIGURE_ARGS += \
37
-	--with-compression
37
+	--with-compression \
38
+	--without-glib
38 39
 
39 40
 define Build/InstallDev
40 41
 	$(INSTALL_DIR) $(1)

+ 33
- 0
libs/ibrdtn/patches/100-add_configure_options.patch 查看文件

@@ -0,0 +1,33 @@
1
+--- a/configure.ac
2
++++ b/configure.ac
3
+@@ -159,12 +159,21 @@ AS_IF([test "x$enable_android" = "xyes"], [
4
+ 	dnl -----------------------------------------------
5
+ 	dnl check for glib support
6
+ 	dnl -----------------------------------------------
7
+-	PKG_CHECK_MODULES([GLIB], [glib-2.0], [
8
+-		AC_SUBST(GLIB_CFLAGS)
9
+-		AC_SUBST(GLIB_LIBS)
10
+-		AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
11
+-		REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
12
+-	], [
13
++	AC_ARG_WITH([glib], [AS_HELP_STRING([--without-glib], [Disable linking to glib-2.0 library])], [with_glib=no], [with_glib=yes])
14
++	AS_IF([test "x$with_glib" != xno],
15
++	[
16
++		PKG_CHECK_MODULES([GLIB], [glib-2.0], [
17
++			AC_SUBST(GLIB_CFLAGS)
18
++			AC_SUBST(GLIB_LIBS)
19
++			AC_DEFINE(HAVE_GLIB, [1], ["glib library is available"])
20
++			REQUIRES_LIBS="$REQUIRES_LIBS glib-2.0"
21
++		], [
22
++			with_glib=no
23
++		])
24
++	], [])
25
++		
26
++	AS_IF([test "x$with_glib" = xno],
27
++	[
28
+ 		AS_IF([test "x$has_endian_h" = "xyes"],[
29
+ 			AC_MSG_NOTICE([use endian.h for endianess conversion])
30
+ 		],[
31
+-- 
32
+1.9.1
33
+