Browse Source

lsof: respect IPv6 settings

Signed-off-by: Alexander Ryzhov <openwrt@ryzhov-al.ru>
Alexander Ryzhov 10 years ago
parent
commit
72322f24ae
1 changed files with 8 additions and 2 deletions
  1. 8
    2
      utils/lsof/Makefile

+ 8
- 2
utils/lsof/Makefile View File

@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
10 10
 
11 11
 PKG_NAME:=lsof
12 12
 PKG_VERSION:=4.86
13
-PKG_RELEASE:=2
13
+PKG_RELEASE:=3
14 14
 
15 15
 PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)+dfsg.orig.tar.gz
16 16
 PKG_SOURCE_URL:=http://ftp2.de.debian.org/debian/pool/main/l/lsof
@@ -32,9 +32,15 @@ define Package/lsof
32 32
   URL:=http://people.freebsd.org/~abe/
33 33
 endef
34 34
 
35
+ifeq ($(CONFIG_IPV6),y)
36
+  LINUX_CLIB_IPV6="-DHASIPv6"
37
+else
38
+  LINUX_CLIB_IPV6=
39
+endif
40
+
35 41
 define Build/Configure
36 42
 	cd $(PKG_BUILD_DIR); \
37
-		LINUX_CLIB="-DGLIBCV=2" \
43
+		LINUX_CLIB="-DGLIBCV=2 $(LINUX_CLIB_IPV6)" \
38 44
 		LSOF_CC="$(TARGET_CC)" \
39 45
 		LSOF_INCLUDE="-I$(STAGING_DIR)/usr/include" \
40 46
 		LSOF_VSTR="$(LINUX_VERSION)" \