Browse Source

mutt: bring back from oldpackages

* import from oldpackages
* bump version and update hash
* update patch to new version
* add PKG_LICENSE, PKG_LICENSE_FILES, PKG_MAINTAINER

Signed-off-by: Phil Eichinger <phil@zankapfel.net>
Phil Eichinger 9 years ago
parent
commit
726a734c32
2 changed files with 80 additions and 0 deletions
  1. 53
    0
      mail/mutt/Makefile
  2. 27
    0
      mail/mutt/patches/0001-no-po-and-docs.patch

+ 53
- 0
mail/mutt/Makefile View File

@@ -0,0 +1,53 @@
1
+#
2
+# Copyright (C) 2006-2015 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=mutt
11
+PKG_VERSION:=1.5.24
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE_URL:=ftp://ftp.mutt.org/pub/mutt/
15
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
16
+PKG_MD5SUM:=7f25d27f3c7c82285ac07aac35f5f0f2
17
+
18
+PKG_LICENSE:=GPL-2.0+
19
+PKG_LICENSE_FILES:=GPL
20
+PKG_MAINTAINER=Phil Eichinger <phil@zankapfel.net>
21
+
22
+
23
+PKG_INSTALL:=1
24
+
25
+include $(INCLUDE_DIR)/package.mk
26
+
27
+define Package/mutt
28
+  SECTION:=mail
29
+  CATEGORY:=Mail
30
+  DEPENDS:=+libopenssl +libncursesw
31
+  TITLE:=Console mail client
32
+  URL:=http://www.mutt.org/
33
+endef
34
+
35
+define Package/mutt/description
36
+	Mutt is a small but very powerful text-based mail client for Unix
37
+	operating systems.
38
+endef
39
+
40
+CONFIGURE_ARGS += \
41
+	--includedir=$(PKG_BUILD_DIR)/. \
42
+	--oldincludedir=$(PKG_BUILD_DIR)/. \
43
+	--enable-pop \
44
+	--enable-imap \
45
+	--with-ssl \
46
+	--without-idn
47
+
48
+define Package/mutt/install
49
+	$(INSTALL_DIR) $(1)/usr/bin
50
+	$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/mutt $(1)/usr/bin/
51
+endef
52
+
53
+$(eval $(call BuildPackage,mutt))

+ 27
- 0
mail/mutt/patches/0001-no-po-and-docs.patch View File

@@ -0,0 +1,27 @@
1
+From b0e285a8c7faaec8807fdd677da6750f341f0109 Mon Sep 17 00:00:00 2001
2
+From: Phil Eichinger <phil@zankapfel.net>
3
+Date: Thu, 19 Nov 2015 13:18:53 +0100
4
+Subject: [PATCH] no po and docs
5
+
6
+[adapted old patch and converted to git patch]
7
+Signed-off-by: Phil Eichinger <phil@zankapfel.net>
8
+---
9
+ Makefile.in | 2 +-
10
+ 1 file changed, 1 insertion(+), 1 deletion(-)
11
+
12
+diff --git a/Makefile.in b/Makefile.in
13
+index 1909835..cfa7ca0 100644
14
+--- a/Makefile.in
15
++++ b/Makefile.in
16
+@@ -458,7 +458,7 @@ get_cs_cmdline = $(call get_cs_compile,$(1)) $(call get_cs_all_flags,$(1),check_
17
+ AUTOMAKE_OPTIONS = 1.6 foreign
18
+ @BUILD_IMAP_TRUE@IMAP_SUBDIR = imap
19
+ @BUILD_IMAP_TRUE@IMAP_INCLUDES = -I$(top_srcdir)/imap
20
+-SUBDIRS = m4 po intl doc contrib $(IMAP_SUBDIR)
21
++SUBDIRS = m4 intl contrib $(IMAP_SUBDIR)
22
+ bin_SCRIPTS = muttbug flea $(SMIMEAUX_TARGET)
23
+ @BUILD_HCACHE_TRUE@HCVERSION = hcversion.h
24
+ BUILT_SOURCES = keymap_defs.h patchlist.c reldate.h conststrings.c $(HCVERSION)
25
+-- 
26
+2.1.4
27
+