|
@@ -0,0 +1,23 @@
|
|
1
|
+--- a/configure.ac
|
|
2
|
++++ b/configure.ac
|
|
3
|
+@@ -27,20 +27,6 @@ AC_PREFIX_DEFAULT(/usr)
|
|
4
|
+
|
|
5
|
+ dnl Checks for programs.
|
|
6
|
+
|
|
7
|
+-dnl try to gues cross-compiler if not set
|
|
8
|
+-if test "x$host" != "x$build" -a -z "`echo $CC | grep -e '-gcc'`";
|
|
9
|
+-then
|
|
10
|
+- AC_MSG_CHECKING(for cross-compiler)
|
|
11
|
+-
|
|
12
|
+- which ${program_prefix}gcc >/dev/null 2>&1 && CC=${program_prefix}gcc
|
|
13
|
+- which ${host_cpu}-${host_os}-gcc >/dev/null 2>&1 \
|
|
14
|
+- && CC=${host_cpu}-${host_os}-gcc
|
|
15
|
+- which ${host_cpu}-${host_vendor}-${host_os}-gcc >/dev/null 2>&1 \
|
|
16
|
+- && CC=${host_cpu}-${host_vendor}-${host_os}-gcc
|
|
17
|
+-
|
|
18
|
+- AC_MSG_RESULT($CC)
|
|
19
|
+-fi
|
|
20
|
+-
|
|
21
|
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
|
|
22
|
+
|
|
23
|
+
|