Browse Source

Merge pull request #164 from MikePetullo/vips

Copy vips package from old repository and update (this is necessary for a forthcoming dmapd package addition)
sbyx 10 years ago
parent
commit
72ebc0ded7
2 changed files with 91309 additions and 0 deletions
  1. 81
    0
      libs/vips/Makefile
  2. 91228
    0
      libs/vips/patches/001-no_cpp.patch

+ 81
- 0
libs/vips/Makefile View File

@@ -0,0 +1,81 @@
1
+#
2
+# Copyright (C) 2010-2012 OpenWrt.org
3
+#
4
+# This is free software, licensed under the GNU General Public License v2.
5
+# See /LICENSE for more information.
6
+#
7
+
8
+include $(TOPDIR)/rules.mk
9
+
10
+PKG_NAME:=vips
11
+PKG_VERSION:=7.38.5
12
+PKG_RELEASE:=1
13
+
14
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
15
+PKG_SOURCE_URL:=http://www.vips.ecs.soton.ac.uk/supported/7.38/
16
+PKG_MD5SUM:=768d1c0f50c5b2794bcab68383af33ee
17
+PKG_FIXUP:=autoreconf
18
+
19
+include $(INCLUDE_DIR)/package.mk
20
+include $(INCLUDE_DIR)/nls.mk
21
+
22
+PKG_INSTALL=1
23
+
24
+define Package/vips
25
+  $(call Package/vips/Default)
26
+  SECTION:=multimedia
27
+  CATEGORY:=Multimedia
28
+  TITLE:=An image manipulation library
29
+  URL:=http://www.vips.ecs.soton.ac.uk/
30
+  MAINTAINER:=W. Michael Petullo <mike@flyn.org>
31
+  DEPENDS:=+glib2 +libexif +libjpeg +libpng +libxml2 $(INTL_DEPENDS)
32
+endef
33
+
34
+TARGET_LDFLAGS+= \
35
+	-Wl,-rpath-link=$(STAGING_DIR)/usr/lib
36
+
37
+CONFIGURE_ARGS += \
38
+	--disable-cxx \
39
+	--disable-threads \
40
+	--without-cfitsio \
41
+	--without-fftw \
42
+	--without-lcms \
43
+	--without-magick \
44
+	--without-matio \
45
+	--without-OpenEXR \
46
+	--without-orc \
47
+	--without-pangoft2 \
48
+	--without-python \
49
+	--without-tiff \
50
+	--without-v4l \
51
+	--without-x \
52
+	--without-zip \
53
+	--with-jpeg \
54
+	--with-libexif \
55
+	--with-png \
56
+
57
+define Build/InstallDev
58
+	$(INSTALL_DIR) $(1)/usr/include/vips
59
+	$(CP) \
60
+		$(PKG_INSTALL_DIR)/usr/include/* \
61
+		$(1)/usr/include/
62
+
63
+	$(INSTALL_DIR) $(1)/usr/lib/
64
+	$(CP) \
65
+		$(PKG_INSTALL_DIR)/usr/lib/*.so* \
66
+		$(1)/usr/lib/
67
+
68
+	$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
69
+	$(INSTALL_DATA) \
70
+		$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
71
+		$(1)/usr/lib/pkgconfig/
72
+endef
73
+
74
+define Package/vips/install
75
+	$(INSTALL_DIR) $(1)/usr/lib/
76
+	$(CP) \
77
+		$(PKG_INSTALL_DIR)/usr/lib/*.so* \
78
+		$(1)/usr/lib/
79
+endef
80
+
81
+$(eval $(call BuildPackage,vips))

+ 91228
- 0
libs/vips/patches/001-no_cpp.patch
File diff suppressed because it is too large
View File