Browse Source

bind: Allow packages to be built with optional filter-aaaa option

Signed-off-by: Noah Meyerhans <frodo@morgul.net>
Noah Meyerhans 9 years ago
parent
commit
734bec0045
2 changed files with 30 additions and 2 deletions
  1. 17
    0
      net/bind/Config.in
  2. 13
    2
      net/bind/Makefile

+ 17
- 0
net/bind/Config.in View File

@@ -0,0 +1,17 @@
1
+if PACKAGE_bind-server
2
+
3
+config BIND_ENABLE_FILTER_AAAA
4
+	bool
5
+	default n
6
+	prompt "Enable filtering of AAAA records returned to the client"
7
+	help
8
+		BIND 9 has an option to filter AAAA (IPv6 address) records
9
+		returned to the client based on the transport used for the
10
+		query, and other filtering conditions. This filtering does
11
+		not affect the recursive queries made by the server (if
12
+		any) as a result of the client request.
13
+
14
+		Additional details are available at
15
+		https://kb.isc.org/article/AA-00576/0/Filter-AAAA-option-in-BIND-9-.html
16
+
17
+endif

+ 13
- 2
net/bind/Makefile View File

@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
10 10
 
11 11
 PKG_NAME:=bind
12 12
 PKG_VERSION:=9.9.8-P3
13
-PKG_RELEASE:=1
13
+PKG_RELEASE:=2
14 14
 USERID:=bind=57:bind=57
15 15
 
16 16
 PKG_MAINTAINER := Noah Meyerhans <frodo@morgul.net>
@@ -27,7 +27,9 @@ PKG_REMOVE_FILES:=aclocal.m4 libtool.m4
27 27
 
28 28
 PKG_INSTALL:=1
29 29
 
30
-PKG_CONFIG_DEPENDS := CONFIG_OPENSSL_WITH_EC
30
+PKG_CONFIG_DEPENDS := \
31
+	CONFIG_OPENSSL_WITH_EC \
32
+	CONFIG_BIND_ENABLE_FILTER_AAAA
31 33
 
32 34
 include $(INCLUDE_DIR)/package.mk
33 35
 
@@ -53,6 +55,10 @@ define Package/bind-server
53 55
   TITLE+= DNS server
54 56
 endef
55 57
 
58
+define Package/bind-server/config
59
+	source "$(SOURCE)/Config.in"
60
+endef
61
+
56 62
 define Package/bind-client
57 63
   $(call Package/bind/Default)
58 64
   TITLE+= dynamic DNS client
@@ -105,6 +111,11 @@ CONFIGURE_ARGS += \
105 111
 	--with-ecdsa=$(if $(CONFIG_OPENSSL_WITH_EC),yes,no) \
106 112
 	--with-readline=no
107 113
 
114
+ifdef CONFIG_BIND_ENABLE_FILTER_AAAA
115
+	CONFIGURE_ARGS += \
116
+		--enable-filter-aaaa
117
+endif
118
+
108 119
 CONFIGURE_VARS += \
109 120
 	BUILD_CC="$(TARGET_CC)" \
110 121