|
@@ -0,0 +1,36 @@
|
|
1
|
+#
|
|
2
|
+# Copyright (C) 2012-2015 OpenWrt.org
|
|
3
|
+#
|
|
4
|
+# This is free software, licensed under the GNU General Public License v2.
|
|
5
|
+# See /LICENSE for more information.
|
|
6
|
+#
|
|
7
|
+
|
|
8
|
+include $(TOPDIR)/rules.mk
|
|
9
|
+
|
|
10
|
+PECL_NAME:=dio
|
|
11
|
+PECL_LONGNAME:=Direct I/O functions
|
|
12
|
+
|
|
13
|
+PKG_VERSION:=0.0.7
|
|
14
|
+PKG_RELEASE:=1
|
|
15
|
+PKG_MD5SUM:=a1a4df428a17dbe1ab4277b492dfa052
|
|
16
|
+
|
|
17
|
+PKG_NAME:=php5-pecl-$(PECL_NAME)
|
|
18
|
+PKG_SOURCE:=$(PECL_NAME)-$(PKG_VERSION).tgz
|
|
19
|
+PKG_SOURCE_URL:=http://pecl.php.net/get/
|
|
20
|
+
|
|
21
|
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PECL_NAME)-$(PKG_VERSION)
|
|
22
|
+PKG_BUILD_PARALLEL:=1
|
|
23
|
+
|
|
24
|
+PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
|
|
25
|
+
|
|
26
|
+PKG_LICENSE:=PHPv3.01
|
|
27
|
+PKG_LICENSE_FILES:=
|
|
28
|
+
|
|
29
|
+PKG_FIXUP:=autoreconf
|
|
30
|
+
|
|
31
|
+include $(INCLUDE_DIR)/package.mk
|
|
32
|
+include $(INCLUDE_DIR)/nls.mk
|
|
33
|
+include ../php5/pecl.mk
|
|
34
|
+
|
|
35
|
+$(eval $(call PECLPackage,$(PECL_NAME),$(PECL_LONGNAME)))
|
|
36
|
+$(eval $(call BuildPackage,$(PKG_NAME)))
|